4
$\begingroup$

I'm having trouble setting-up a parallel remote kernel. I have correctly set-up remote kernels and can use them instead of the local kernels, by executing tunnel.sh script as explained here

However I can't manage to use remote parallel kernels in addition to the local kernels. I tried to use the WolframSSH.jar as described here

MathKernel process is launched, but dies after a few second of freeze.

Then I tried with :

LaunchKernels[
     SubKernels`RemoteKernels`RemoteMachine["remote", 
          "ssh -v remoteuser@remoteIP math -mathlink -linkmode Connect \
          `4` -linkname `2` -subkernel -noinit 1>out.txt 2>err.txt"
     ]
]

The MathKernel process launches on the remote machine, but dies straight away

The out.txt output is then:

LinkConnect::linkc: -- Message text not found -- ( LinkObject[46644@remoteIP,52289@remoteIP, 3, 1])

The err.txt output is then:

debug1: Sending command: math -mathlink -linkmode Connect -linkprotocol TCPIP -linkname 46644@remoteIP,52289@remoteIP -subkernel -noinit debug1: client_input_channel_req: channel 0 rtype exit-status reply 0 debug1: channel 0: free: client-session, nchannels 1 debug1: fd 0 clearing O_NONBLOCK debug1: fd 1 clearing O_NONBLOCK debug1: fd 2 clearing O_NONBLOCK Transferred: sent 3232, received 2412 bytes, in 0.3 seconds Bytes per second: sent 12332.3, received 9203.4 debug1: Exit status 1

Local and remote machine are running Mathematica 10.0 under Linux (Ubuntu). I'm not using a VPN but just ssh connection.

Any ideas ?

$\endgroup$
  • 1
    $\begingroup$ Tell us about your infrastructure configuration, including number of processors; types of machines and operating systems (local and remote); network (including your local and remote networks, and what VPN you use if any); number of Mma licenses; license versions. Best to add all of this to your question. $\endgroup$ – Jagra May 7 '15 at 16:59
  • $\begingroup$ Somewhat related. Note that WolframSSH.jar in v10 seems to have some problems with it. $\endgroup$ – bobthechemist May 7 '15 at 23:29
2
$\begingroup$

I've solved the problem by using the tunnel_sub.sh from Sacha Kratky script provided here. Thank you

$\endgroup$
  • $\begingroup$ The Tunnel scripts are now hosted at GitHub. $\endgroup$ – sakra Jun 7 '15 at 14:27
  • $\begingroup$ The tunneling works perfectly here. Windows - Windows setup. Thanks. $\endgroup$ – masterxilo Feb 6 '17 at 0:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.