7
$\begingroup$

I'm a student using Mathematica on a 2012 macbook pro with OS X Yosemite. Mathematica was running fine on my computer for a long time - one day, seemingly randomly, a blank screen started appearing whenever I open Mathematica. It makes one desktop on my computer (wherever the Mathematica start up screen is) unusable, and it makes it hard to close Mathematica notebooks because when you exit full screen, the notebook goes to the unusable desktop. Screen shot attached. Whenever I quit Mathematica it also always asks if I want to save the changes made to any random Mathematica notebook on my computer, even if I open and quit Mathematica without making any changes to anything. I can work around it, but it's certainly annoying.

enter image description here

This started happening when I was running on Mathematica version 10.0.1.0. I updated to 10.0.2 and it solved the problem for a couple days, then one day when I opened Mathematica it started again. Has anybody encountered anything similar to this, or does anybody have any ideas of solutions?

Any and all ideas would be greatly appreciated - thanks a ton!!

$\endgroup$
  • 8
    $\begingroup$ As a first shot, try deleting ~/Library/Preferences/com.wolfram.Mathematica.plist and ~/Library/Saved\ Application\ State/com.wolfram.Mathematica.savedState/. These files and directories can keep window state around. $\endgroup$ – Christopher Cole Apr 27 '15 at 20:41
  • $\begingroup$ @ChristopherCole I'd say this comment would be useful as an answer to make it permanent. $\endgroup$ – Yves Klett Apr 28 '15 at 20:34
  • $\begingroup$ For me, I think the issue might have been created by opening a notebook with the option WindowSize->{Full, Full}. $\endgroup$ – user2309840 May 17 '16 at 17:39
2
$\begingroup$

Yep.

Click the blank, white window(s) that are blocking your desktop. Then, hit Control + Command + F (on a Mac — surely there's a PC equivalent). This should make your white window expand, and your problem should be solved.

$\endgroup$
2
$\begingroup$

Quoting Christopher Cole, which 7 people seem to have found useful,

As a first shot, try deleting:

~/Library/Preferences/com.wolfram.Mathematica.plist and ~/Library/Saved\ Application\ State/com.wolfram.Mathematica.savedState/

These files and directories can keep window state around.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.