I like writing integrals symbolically instead of using Integrate[]. I suddenly seem to not be able to do this and am confused. I type \[Esc] int \[Esc] then \[Ctrl] + _ for my lower bound, and online it says use \[Ctrl] + % for the upper bound, but nothing happens. I've also tried using \[Ctrl] + ^ which here says it is a superscript, and that gets me somewhere. However, I get a syntax error.

So for the \[Ctrl] + ^ case, I'm typing \[Esc]int\[Esc]\[Ctrl]+_0\[rightarrow]\[Ctrl]+^1 2 \[Esc]dd\[Esc]x and I get the syntax error

Syntax::sntxi: Incomplete expression; more input is needed .

I've also tried putting parenthesis around the integrand, but it doesn't help. On the screen it looks fine:enter image description here

So why doesn't the \[Ctrl] + % do anything? And ultimately, how do I get this symbolic integral to evaluate? Thanks for the help.

  • $\begingroup$ You should use \[Ctrl] + % for upper bound, it works for me (M10.1, Windows 8.1). \[Ctrl] + ^ is a superscript, it's an index. $\endgroup$ – m0nhawk Apr 21 '15 at 14:43
  • 1
    $\begingroup$ Try Ctrl-5. On a US English keyboard the % sign is above 5. What is your keyboard layout? $\endgroup$ – Szabolcs Apr 21 '15 at 14:44
  • $\begingroup$ \[Esc] int \[Esc] (\[Ctrl] + -) 0 (\[Ctrl] + 5) x \[RightArrow] Sin[y] \[Esc] dd \[Esc] y (\[Shift] + \[Return]) returned the expected 1 - Cos[x] (M10.0.1 Win7x64). Standard US keyboard. $\endgroup$ – LLlAMnYP Apr 21 '15 at 14:52
  • $\begingroup$ When I type (in my US keyboard, M10.0, Windows 8.1) \[Ctrl]+% literally nothing happens. I have typed these several times in the past and have no issues. Even when I run old notebooks I see this formatting and it runs fine. $\endgroup$ – user46348 Apr 21 '15 at 14:52
  • $\begingroup$ Maybe a restart of windows or the kernel? Failing that I'm pressed to suggest anything else. $\endgroup$ – LLlAMnYP Apr 21 '15 at 15:00

Instead of adding first a subscript and then a separate superscript, you need to add joint pair. Ctrl-% moves between the sub- and superscripts, but the actual keyboard shortcut may be dependent on your keyboard layout. Also try Ctrl-5.

You can look up the shortcut next to the Insert → Typesetting → Opposite Position menu item.

On my computer I see Ctrl-5 in the menu.


If you cannot resolve the keyboard behavior try an alternate input form; I propose:


To input:

enter image description here

Then use Tab to move between the Placeholder fields.

  • 3
    $\begingroup$ Strangely if one types '[esc]din', this is not offered as a completion $\endgroup$ – m_goldberg Apr 21 '15 at 16:15
  • $\begingroup$ @m_goldberg An oversight perhaps? It is shown in a Tooltip in the Basic Math Assistant palette. $\endgroup$ – Mr.Wizard Apr 21 '15 at 16:19
  • $\begingroup$ Yes, it would appear so. I'm thinking of reporting it to WRI. $\endgroup$ – m_goldberg Apr 21 '15 at 16:21
  • 2
    $\begingroup$ Thanks for this suggestion. The \[Tab] trick is neato. $\endgroup$ – user46348 Apr 21 '15 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.