4
$\begingroup$

I use Mathematica 9.0.1.0 on Mac OS X 10.10.3.

As an example of my issue, we can follow along with the example from the documentation page for $OutputSizeLimit. Quoting from that page:

This produces output that is somewhat lengthy:

In[1]:= Expand[(x + 3 y)^27]

Out[1]= x^27 + 81 x^26 y + 3159 x^25 y^2 + 78975 x^24 y^3 + 1421550 x^23 y^4 + 19617390 x^22 y^5 + 215791290 x^21 y^6 + 1942121610 x^20 y^7 + 14565912075 x^19 y^8 + 92250776475 x^18 y^9 + 498154192965 x^17 y^10 + 2309623985565 x^16 y^11 + 9238495942260 x^15 y^12 + 31979409030900 x^14 y^13 + 95938227092700 x^13 y^14 + 249439390441020 x^12 y^15 + 561238628492295 x^11 y^16 + 1089463220014455 x^10 y^17 + 1815772033357425 x^9 y^18 + 2580307626350025 x^8 y^19 + 3096369151620030 x^7 y^20 + 3096369151620030 x^6 y^21 + 2533392942234570 x^5 y^22 + 1652212788413850 x^4 y^23 + 826106394206925 x^3 y^24 + 297398301914493 x^2 y^25 + 68630377364883 x y^26 + 7625597484987 y^27

Set $OutputSizeLimit to be rather small:

In[2]:= $OutputSizeLimit = 4000

Out[2]= 4000

Now the same output as before is shown in a shortened form:

In[3]:= Expand[(x + 3 y)^27]

Out[3]=

A very large output was generated. Here is a sample of it.

x^27 + 81 x^26 y + 3159 x^25 y^2 + 78975 x^24 y^3 +
 1421550 x^23 y^4 + 19617390 x^22 y^5 + 215791290 x^21 y^6 + 
 1942121610 x^20 y^7 + <<13>> + 3096369151620030 x^6 y^21 + 
 2533392942234570 x^5 y^22 + 1652212788413850 x^4 y^23 + 
 826106394206925 x^3 y^24 + 297398301914493 x^2 y^25 + 
 68630377364883 x y^26 + 7625597484987 y^27

[Show Less]   [Show More]   [Show Full Output]   [Set Size Limit…]

So far so good. But when I click any of the "Show Less", "Show More", or "Show Full Output" buttons, I am faced with the following error message:

$OutputSizeLimit::noout: This output cannot be updated because Out[3] has no value.

This occurs for any "very large output" in any notebook. What is going wrong and how can I fix this?

$\endgroup$
  • 1
    $\begingroup$ What evaluation of $HistoryLength returns for you? $\endgroup$ – Alexey Popkov Apr 12 '15 at 5:49
  • $\begingroup$ Wow: You got it in one guess! Absolutely right, I had set $HistoryLength = 0 to help with memory consumption. $\endgroup$ – thecommexokid Apr 12 '15 at 5:59
10
$\begingroup$

The reason is that you have empty history because you set $HistoryLength = 0 (as you confirm in the comments). I recommend setting $HistoryLength to be at least 3 in order to get the [Show Full Output] button working in the most practical cases.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.