6
$\begingroup$

The problem has gone, presumably resolved by WRI. See kirma's comment.


I'm using Mathematica 10.0.2 for Mac, and for the first time just tried CountryData.

Executing the first example in the documentation of CountryData is fine:

CountryData["France", "Population"]

but the second one fails:

CountryData["G8"]

with the following error messages:

General::aofil: /Users/ME/Library/Mathematica/Paclets/Repository/CountryData-9.0.64/Data/CountryData.wdx already open as /Users/ME/Library/Mathematica/Paclets/Repository/CountryData-9.0.64/Data/CountryData.wdx. >>

OpenWrite::noopen: Cannot open /Users/ME/Library/Mathematica/Paclets/Repository/CountryData-9.0.64/Data/CountryData.wdx. >>

General::stream: $Failed is not a string, InputStream[ ], or OutputStream[ ]. >>

General::stop: Further output of General::stream will be suppressed during this calculation. >>

SetFileDate::nffil: File not found during SetFileDate[/Users/ME/Library/Mathematica/Paclets/Repository/CountryData-9.0.64/Data/CountryData.wdx,{2014,3,7,13,31,4}]. >>

What could possibly be the cause of this?

Do you have any suggestions for what I should try to restore the functionality of CountryData?

Update

As reported in the comments, I've removed my previous ~/Library/Mathematica/Paclets/Temporary. Now CountryData["G8"] just gives me

$Failed

without anything else.

$\endgroup$
  • $\begingroup$ have you tried RebuildPacletData[]? I think that problem has already come up, there seems to be a problem when updating from v9 to v10 but I can't find the question for the moment... $\endgroup$ – Albert Retey Apr 8 '15 at 21:55
  • $\begingroup$ Sadly that doesn't help... $\endgroup$ – Taiki Apr 8 '15 at 23:51
  • $\begingroup$ I cannot reproduce your problem on my Mac with v10.0.2 Have you tried starting with a fresh kernel? Or restarting your Mac? $\endgroup$ – Bob Hanlon Apr 9 '15 at 0:00
  • $\begingroup$ Are you still getting the same error messages? A brute force alternative to guarantee you have a clean state would be to delete all 9.x files/directories in Paclets/Repository and then do RebuildPacletData, but probably what I have in mind is not your problem... $\endgroup$ – Albert Retey Apr 9 '15 at 7:35
  • 1
    $\begingroup$ I have had this problem on v10.1 and contacted WRI support after trying out all possible paclet remedies. The response wasn't exactly pleasing; I really feel they were trying to dodge around responsibility for the problem on their end. This was about two weeks ago for several days in succession - when I try it now it seems to work! $\endgroup$ – kirma May 10 '15 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.