I'm trying to follow the documentation on how to get mathpsfrag set up on Windows 8 (64-bit). It failed at the line

If[MathPSfragConfigurationTest[] === True, okPrint["Passed"], errorPrint["Failed"]];

saying that it found latex and dvips but not ghostscript. So then I found the paths for latex.exe, dvips.exe, and gswin64c.exe and put them into the UnPSfrag part as so:

    GhostscriptExecutable -> "C:\\Program Files\\gs\\gs9.15\\bin\\gswin64c",
    LaTeXExecutable ->    "C:\\Program Files\\MiKTeX 2.9\\miktex\\bin\\x64\\latex",
    DvipsExecutable ->    "C:\\Program Files\\MiKTeX 2.9\\miktex\\bin\\x64\\dvips"]; 
If[MathPSfragConfigurationTest[] === True, okPrint["Passed"], errorPrint["Failed"]];

I also tried with .exe at the ends of the names, and with .exe at just the end of the gswin64c one (as in the example in that same file -- not really sure why their example does that). When I do this, now it won't even find latex! The only thing I can think of is maybe the folders have admin-only privileges or something weird?

  • $\begingroup$ Could you link to the documentation of mathpsfrag or MathPSfragConfigurationTest? I can't find it in the built-in documentation. Are you using some kind of external party package? $\endgroup$ Commented Mar 29, 2015 at 9:14
  • $\begingroup$ I guess that would have been helpful. =P wwwth.mpp.mpg.de/members/jgrosse/mathpsfrag/files/manual.pdf specifically sections 3.2 and 5.4 $\endgroup$
    – Hanmyo
    Commented Mar 29, 2015 at 9:30
  • $\begingroup$ Also the files are just from their main site: wwwth.mpp.mpg.de/members/jgrosse/mathpsfrag MathPSfrag 2 (zip) under the Download section $\endgroup$
    – Hanmyo
    Commented Mar 29, 2015 at 9:32
  • 2
    $\begingroup$ You might be interested in MaTeX which seems to be able to do similar things, but looks simpler. $\endgroup$ Commented Mar 29, 2015 at 11:52
  • 3
    $\begingroup$ I'm voting to close this question as off-topic because it deals with the installation process for a third-party package. $\endgroup$
    – MarcoB
    Commented Mar 12, 2016 at 4:23

1 Answer 1


In order to use MathPSFrag on Windows system the file paths should be in correct "full path" form (explicit extra quoting with "\"fullpath\"" worked for me):

"LaTeXExecutable" -> "\"c:\\Latex\\MikTexPortable\\miktex\\bin\\latex.exe\"", 
"DvipsExecutable" -> "\"c:\\Latex\\MikTexPortable\\miktex\\bin\\dvips.exe\"", 
"GhostscriptExecutable" -> "\"c:\\Latex\\GsViewPortable\\gs8.64\\bin\\gswin32c.exe\""]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.