1
$\begingroup$

I wanted to use the following unit

cMax = Quantity[6.8221*^-9, "L/s/bar"];

But when calculating with it, I recognised there is some strange behaviour. So I tried to convert it to L/s/Pa

cMax = Quantity[6.8221*^-9, "L/s/bar"]
UnitConvert[%, "L/s/Pa"]

enter image description here

So why do I get the unit IndependentUnit[bars difference]?

I also tried "Liters/Bars/Seconds", "L/s/Bars", "L/s/Bar", ....

$\endgroup$
4
$\begingroup$

Wolfram Alpha had trouble interpreting your first unit and gave "bar" as IndependentUnit["bars difference"], i.e. it did not know it was pressure.

You can use the proper syntax and WA will not need to be called:

UnitConvert[Quantity[6.8221*^-9, "Liters"/("Bars" "Seconds")], "L/s/Pa"]
Quantity[6.8221*10^-14, "Liters"/("Pascals" "Seconds")]

I found the proper syntax by evaluating each unit separately:

FullForm /@ {Quantity[1, "L"], Quantity[1, "s"], Quantity[1, "bar"]}
{Quantity[1, "Liters"], Quantity[1, "Seconds"], Quantity[1, "Bars"]}
$\endgroup$
  • $\begingroup$ The tip with FullForm was exactly what I needed. I often had such a Problem and never knew how to get the exact form for the unit. $\endgroup$ – Phab Mar 5 '15 at 8:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.