I want to generate a plot using Plot, copy it and paste to a Word/PowerPoint document as a vector EMF file in order to preserve best quality of an image. However I found out that if I Copy Graphic and Paste Special as Picture (Enhanced Metafile) is inserts not vector but raster (pixelized) image. The same behavior I see if use Save Graphic As to an EMF file.

I found one answer BarChart rasterized in EMF export, but in its code

plot = BarChart[{1, 2, 3}, 
   ChartBaseStyle -> 
    EdgeForm[Directive[GrayLevel[0.356], Opacity[1]]]] /. {Opacity[0], __} -> {}

Export["test.emf", plot]


General::unavail: Export is not available in this version of the Wolfram Language.

How do I achieve my task?

Thank you.

  • $\begingroup$ Can you try to use the Encapsulated Postscript (.eps) format instead? Mathematica correctly exports .eps files as vector graphics, and Word will import them. (At least, that's what I read... I use LibreOffice here at home, so I can't test it out.) $\endgroup$ Commented Feb 21, 2015 at 2:33
  • $\begingroup$ The Opacity trick definitely works. Your issue is not the EMF issue, it's that you can't use Export at all. $\endgroup$
    – Verbeia
    Commented Feb 21, 2015 at 10:08

1 Answer 1


You main problem is that you are using a trial version, so some functions are disabled. See the discussions here and here. As such, you first solution would be to upgrade your trial version to a full version. You could also save the file to PDF or EPS with the 'save graphic as' command, and convert that to other vector formats. This is usually pretty simple, and works if your graphics are not overly customized. Using the export command is the only consistent way to maintain image quality, though, so try to upgrade!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.