5
$\begingroup$

This question already has an answer here:

On Windows and OS X, if Mathematica is already running, double clicking a notebook doesn't open a new Front End instance. Instead it will conveniently open the notebook in the already running instance.

How can I achieve the same behaviour on Linux?

Running

mathematica mynotebook.nb

from the command line always opens a completely new instance of the Front End on Linux, even if another Front End was already running. I believe graphical file managers simply run this command when double clicking a notebook.

$\endgroup$

marked as duplicate by Mr.Wizard Jul 17 '15 at 9:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    $\begingroup$ Mine always opens directly; I forget if I had to change one of the settings for this to take place, though. $\endgroup$ – DumpsterDoofus Feb 16 '15 at 13:57
  • $\begingroup$ Mine opens directly as well, using Mathematica 10.0.2.0 under Windows 8.1 (64x). I am confident that I have not changed settings to accomplish this. $\endgroup$ – bbgodfrey Feb 16 '15 at 14:15
  • $\begingroup$ Also opens directly, using Mathematica 9.0.1.0 under Windows 8.1 (64x). $\endgroup$ – bbgodfrey Feb 16 '15 at 15:00
  • $\begingroup$ Very embarrassingly for me, I just realized that this was a duplicate of mathematica.stackexchange.com/questions/13602/… $\endgroup$ – Szabolcs Jul 17 '15 at 8:54
  • $\begingroup$ @Szabolcs Bounty returned; go apply it to the original. $\endgroup$ – Mr.Wizard Jul 17 '15 at 9:01
1
$\begingroup$

In the lower left corner of the welcome screen, there is a checkbox labeled "Show at startup". Uncheck it to bypass the welcome screen.

Alternatively, bring up the Options Inspector (Format > Options Inspector...) and search for "ShowAtStartup". Make sure the pull down menu in the upper left reads "Global Preferences" and choose "NewDocument" for the value of "ShowAtStartup".

$\endgroup$
  • $\begingroup$ But, notebooks open for me by double-clicking, and I do not need to do this. Also, "ShowAtStartup" is set to "Welcome". Perhaps, the behavior in question depends on the version of Mathematica $\endgroup$ – bbgodfrey Feb 16 '15 at 14:37
  • $\begingroup$ It opens a new document instead of opening the file on which I am double-clicking. $\endgroup$ – user22180 Feb 18 '15 at 13:23
  • $\begingroup$ As I understand, the OP has two problems: 1. double clicking a notebook open a completely new instance of the Mathematcia front end instead of opening the notebook in the existing one 2. he says that the notebook isn't even opened in the new instance. I have problem 1 but not problem 2. Unchecking "Show at startup" will not fix problem 1, just hide it. The underlying problem is that it can't figure out that a different front end is already running ... $\endgroup$ – Szabolcs Jul 17 '15 at 8:39
  • $\begingroup$ I thought I'd edit the OP's question to clarify this a bit (instead of asking a completely new question). That might make your answer look a bit out of place ... apologies in advance for this. $\endgroup$ – Szabolcs Jul 17 '15 at 8:40
  • $\begingroup$ @Szabolcs It won't be the first time I've looked awkward. $\endgroup$ – Daniel W Jul 18 '15 at 0:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.