3
$\begingroup$

I use << Notation in my init.m to load some custom notations, but now every time I start the kernel the palette always shows up, is any way to stop that?

I tried using NotebookClose[nb] but I don't know how to get a handle on that palette to use for the argument.

$\endgroup$
4
$\begingroup$

From the Notation.m package:

AutoLoadNotationPalette is a boolean variable. If False then the Notation palette will not be loaded when the Notation package is loaded. If the value is undefined or True the Notation palette will be loaded when the Notation package loads. Other package designers can set this variable outside of the Notation package through a statement similar to Notation`AutoLoadNotationPalette = False.

So, to prevent the palette from loading you can simply use:

Notation`AutoLoadNotationPalette = False;
<< "Notation`"

To close an already open Notation Palette you can use

NotebookClose[Notebooks["Notation Palette"][[1]]]
$\endgroup$
  • $\begingroup$ no +1 because you didn't bother to look for an easy to find duplicate -- boo hiss -- Mr.Grouch $\endgroup$ – Mr.Wizard Feb 14 '15 at 23:32
  • $\begingroup$ Mr.Wizard, fair enough:) $\endgroup$ – kglr Feb 14 '15 at 23:42
2
$\begingroup$

The following worked for me.

 Needs["Notation`"]

 findNotationPalette[nb_] := 
   If[Options[nb, WindowTitle] == {WindowTitle -> "Notation Palette"}, nb, Null]

 closeNotationPalette[] :=
   Module[{notationNB},
     notationNB = Cases[findNotationPalette /@ Notebooks[], _NotebookObject]; 
     If[Length @ notationNB == 1, NotebookClose[notationNB[[1]]], Return[$Failed]]]

closeNotationPalette[]
$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.