0
$\begingroup$

I would like to Plot a simple Vector Field, all vectors normalized to one. If i for example take a evenly distributed sample of the field and plot it with the ListVectorPlot function, i get a plot where position and length of the vectors differs (strongly) from the data:
enter image description here

field={{{{2, 0.}, {1., 0.}}, {{2, 0.1}, {0.982017, 0.188795}}, {{2, 
0.2}, {0.951929, 0.306318}}, {{2, 0.3}, {0.917796, 
0.397053}}, {{2, 0.4}, {0.8818, 0.471624}}, {{2, 0.5}, {0.845307, 
0.534281}}}, {{{3, 0.}, {1., 0.}}, {{3, 0.1}, {0.976522, 
0.21542}}, {{3, 0.2}, {0.960011, 0.279961}}, {{3, 0.3}, {0.942248,
 0.334916}}, {{3, 0.4}, {0.923184, 0.384358}}, {{3, 
0.5}, {0.903192, 0.429238}}}, {{{4, 0.}, {-1., 0.}}, {{4, 
0.1}, {0.889109, 0.457696}}, {{4, 0.2}, {0.950692, 
0.310138}}, {{4, 0.3}, {0.947352, 0.320194}}, {{4, 
0.4}, {0.938342, 0.345709}}, {{4, 0.5}, {0.92731, 
0.374295}}}, {{{5, 0.}, {-1., 0.}}, {{5, 0.1}, {-0.923402, 
0.383834}}, {{5, 0.2}, {0.902614, 0.43045}}, {{5, 0.3}, {0.941445,
 0.337166}}, {{5, 0.4}, {0.943004, 0.332782}}, {{5, 
0.5}, {0.938529, 0.3452}}}, {{{6, 0.}, {-1., 0.}}, {{6, 
0.1}, {-0.992932, 0.118681}}, {{6, 0.2}, {0.508632, 
0.860984}}, {{6, 0.3}, {0.920174, 0.39151}}, {{6, 0.4}, {0.941035,
 0.338309}}, {{6, 0.5}, {0.943283, 0.33199}}}, {{{7, 0.}, {-1., 
0.}}, {{7, 0.1}, {-0.998006, 0.0631237}}, {{7, 0.2}, {-0.81308, 
0.582152}}, {{7, 0.3}, {0.856928, 0.515436}}, {{7, 
0.4}, {0.932176, 0.362005}}, {{7, 0.5}, {0.943793, 
0.330536}}}, {{{8, 0.}, {-1., 0.}}, {{8, 0.1}, {-0.999176, 
0.0405798}}, {{8, 0.2}, {-0.967365, 0.253388}}, {{8, 
0.3}, {0.60162, 0.798783}}, {{8, 0.4}, {0.912304, 0.409513}}, {{8,
 0.5}, {0.940548, 0.339661}}}}; 
ListVectorPlot[field, VectorPoints -> All]    

Why is that?

$\endgroup$

1 Answer 1

0
$\begingroup$

Your vectors are normalized, but your PlotRange is not. If you rescale your plot you can see this:

ListVectorPlot[field, VectorPoints -> All, AspectRatio -> 1/10, ImageSize -> 700]
$\endgroup$
4
  • $\begingroup$ Apparently i lack the reputation to do so, im sorry. But thank you for the answer anyways! $\endgroup$
    – Peter
    Jan 15, 2015 at 14:46
  • $\begingroup$ Adding the option VectorScale -> Small makes this look less cluttered. $\endgroup$
    – Bob Hanlon
    Jan 15, 2015 at 14:53
  • $\begingroup$ AspectRatio -> Automatic will draw the plot with the same aspect ratio as the data. $\endgroup$
    – user484
    Jan 15, 2015 at 17:08
  • $\begingroup$ Thanks, using all that i got some pretty neat plots now! $\endgroup$
    – Peter
    Jan 16, 2015 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.