I have a puzzling and very specific question. It may be of limited interest to community. I apologize in advance in this case. Let us see.

I am making an illustration to a text that I write in the StyleSheet Journal Article. Here is the code:

Column[{   Row[{Rotate[Text[Style["Name of y variable", 18, Bold]], \[Pi]/2], im}],
Row[{Spacer[50], Text[Style["Name of x variable", 18, Bold]]}]   }]

Here is an image with ImageSize->200 copied from somewhere. For example this:

enter image description here

It is fine, while I keep the result of the above code as an output. However, for the sake of numeration of images through the long document I transform the output cell style into the Figure cell style. Such a cell style does not exist in the default stylesheet, but one finds it in the document prepared with the help of the JournalArticle StyleSheet.

My problem is that as soon as I transform the output into the Figure style, the texts "Name of y variable" and "Name of x variable" appear with explicit quotes.

It is not unacceptable, but boring, since the unnecessary information is misleading to the reader. I would be grateful for a suggestion, if there is an easy way to remove the quotes.

  • 3
    $\begingroup$ After transformation to the Figure style, adding ShowStringCharacters-> False to the Cell expression (Shift- control-E on a PC) might be of help on an individual basis? $\endgroup$
    – user1066
    Jun 20, 2012 at 14:21
  • $\begingroup$ Thank you very much, this helps. $\endgroup$ Jun 21, 2012 at 8:13
  • $\begingroup$ I would say, that with this comment my question is solved. $\endgroup$ Jun 21, 2012 at 14:22

2 Answers 2


Select Format > Edit Stylesheet..., then type Figure into the input field to modify the style for your notebook. Select the newly created cell, and use the option inspector to change the setting for ShowStringCharacters to False.

Alternately, you could include ShowStringCharacters -> False in your uses of Style (after the Bold, for example.)


If your variable is a string then use:

Column[{ Row[{Rotate[Text[Style[Name of y variable, 18, Bold]], [Pi]/2], im}],

Row[{Spacer[50], Text[Style[Name of x variable, 18, Bold]]}] }]

Otherwise you may need to change your variable to a string first but either way the quotes in your code are not needed.

  • 1
    $\begingroup$ Thank you, I have tried it first of all. If it is not a string i.e. the text without the quotes, but consisting of few words (as it is in this example: Name of y variable), Mathematica changes the order of the words. $\endgroup$ Jun 20, 2012 at 12:36
  • $\begingroup$ @Alexei Boulbitch is your variable a string? Can you show the code that fills the variable and the result? Testing your code as posted produces the name correctly without quotes, so the error is up stream in your code. $\endgroup$ Jun 20, 2012 at 13:04
  • $\begingroup$ The code is exactly what I posted above plus before this code I defined im to be the image that you also see above. Well the string content is different, say instead of the string "Name of x variable" I have "Time (min)", but this does no difference. $\endgroup$ Jun 21, 2012 at 8:04
  • 1
    $\begingroup$ As I already stated above, the output produced no quotes, that is right. However, as soon as I select the output cell with the result and go to Menu/Format/Style/Figure in order to produce the cell with the figure style, I get it, but the text appears differently: with the quotes. The cell style "Figure" one finds within the JournalArticle StyleSheet, and it is essential. $\endgroup$ Jun 21, 2012 at 8:08
  • 1
    $\begingroup$ I use M8.0.4.0 on PC, Windows XP. You do not see the Figure because there is not such an item there. Transform your notebook into the JournalArticle StyleSheet and you will find it. $\endgroup$ Jun 21, 2012 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.