Update: This behaviour happens only if cell grouping is set to Manual (similar to another problem).


When an output cell is generated by e.g. dynamical object, the output is printed faded out. This behaviour was introduced in v10 with multiple undo to indicate if an output cell is decoupled from its input cell due to manually editing the input cell. This, however, is an unwanted behaviour for some cases; consider this example:

SetOptions[$FrontEndSession, CellGrouping -> Manual];
g = Graphics[{Red, Disk[], Green, Rectangle[{0, 0}, {2, 2}],
              Blue, Disk@{2, 2}}, ImageSize -> 100];
Print@g;
Button["Print", Print@g]

faded output cell

When the button is pushed, it generates the bottom output cell that has a faded look by default. A large amount of text (instead of graphics) is hard to read when faded.

How to print output from within a dynamical expression so that it does not look faded? Needless to say, I need the resulting cell to be an output cell (for example, it is removed when the Delete All Output menuitem is selected). Is there an option that controls this behaviour?

(Version is 10.0.2.0, Windows 7 (64-bit))

  • Cannot reproudcue this issue on 10.0.2 (Win7 64). Which version / system are you using? – Yves Klett Jan 6 '15 at 9:21
  • 1
    @Yves same as yours. My FrontEnd has always produced some strange glitches unreproducable by many... Also, Find&Replace window crashes all the time. BTW, do you have the default behaviour of editing an input cell and thus fading out its output? – István Zachar Jan 6 '15 at 9:41
  • Just a guess, but perhaps your gfx (drivers?) are buggy? – Yves Klett Jan 6 '15 at 9:46
  • @YvesKlett Could you please test/confirm whether CellGrouping->Manual triggers the behaviour at your end? – István Zachar Apr 3 '15 at 9:50
  • Why do you use CellGrouping->Manual? What are you trying to achieve that you can't achieve other ways? I've seriously considered deprecating manual cell grouping (since it's easy to manually group cells under automatic grouping), and I'd like to understand what you find interesting about it. – John Fultz Apr 6 '15 at 14:11
up vote 11 down vote accepted

The dimming is controlled by the option PrivateCellOptions->{"EvaluationUnmatchedStyle"}. It must be applied at the cell level, but this is easy to do in your example by using CellPrint with the "Print" style to match what Print does.

CellPrint @ ExpressionCell[
  g, "Print", PrivateCellOptions -> {"EvaluationUnmatchedStyle" -> {}}
]

To disable it on a global level you can do:

CurrentValue[$FrontEnd, {PrivateCellOptions, "EvaluationUnmatchedStyle"}] = {};
  • John, would it be possible to modify a global setting so that this feature is disabled by default in my installation? – MarcoB May 30 '15 at 21:48
  • 2
    @MarcoB, set the aforementioned option setting on $FrontEnd. I.e., CurrentValue[$FrontEnd, {PrivateCellOptions, "EvaluationUnmatchedStyle"}] = {} – John Fultz Jun 9 '15 at 17:30
  • Awesome, thank you! – MarcoB Jun 9 '15 at 17:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.