I export my Mathematica generated plot as an eps file and then I open it in Adobe Illustrator to make a few changes. When I try to do this I get this error message:

Times-Roman: Font not found on the system; missing font has been substituted.

But the substituted font looks terrible.

How can I make Illustrator load the correct fonts on a Windows 7 box?

  • 1
    $\begingroup$ Could you provide a small Plot example that exhibits this behavior? Please also include the specific Export command you use. $\endgroup$ Commented Jun 17, 2012 at 7:15
  • $\begingroup$ I did it in the past with Illustrator. At that time I exported the graphics without any text. It was for the same reason. I added then the text by hands already within the Illustrator, along with some minor additional graphics, such as some lines arrows etc. Now I prefer to finalize everything in Mma. $\endgroup$ Commented Feb 20, 2014 at 16:14

2 Answers 2


I don't run Windows, but I do know how to fix this problem on Mac OS X (see my web page).

Based on that, I can at least provide a guess as to what you should do. However, I can't guarantee that it will work because I have no way to try it. So use this prescription at your own risk:

  • Download the Mathematica fronts from the official web site (they also come with MMA, but I don't know where they reside on Windows).
  • In the extracted directory, locate the Type1 folder
  • In another window, find the directory <System Disk>:\Program Files\Common Files\Adobe\Fonts (the Adobe folder should already exist, but you may have to create the Fonts folder.
  • Drag the Type1 folder found in the first step into the directory found in the last step.

Now restart Illustrator, and with some luck you'll have the Math fonts available.

  • 1
    $\begingroup$ The Type1 folder does not contain the Times-Roman font mentioned in the question. $\endgroup$ Commented Jun 17, 2012 at 5:36
  • $\begingroup$ The same error message, but the substituted font is a lot nicer! thanks $\endgroup$
    – AUK1939
    Commented Jun 17, 2012 at 5:52
  • 1
    $\begingroup$ Thank you! It worked! If there's still a missing font we can now just copy it to that folder. $\endgroup$
    – user1607
    Commented Jun 28, 2012 at 22:26
  • 1
    $\begingroup$ Just a heads up: In Win8, this worked by exporting all the fonts in the Type1 folder into C:\Program Files\Adobe\Adobe Illustrator CC (64 Bit)\Support Files\Required\Fonts. I could not find the path that @jens provided in the answer $\endgroup$
    – Sos
    Commented Feb 20, 2014 at 16:00
  • 1
    $\begingroup$ Would you kindly update your answer for Mathematica 10? Copying the fonts to the Adobe\Fonts directory doesn't seem to work anymore. (Mac OSX) $\endgroup$
    – QuantumDot
    Commented Oct 11, 2015 at 20:03

I appreciate the solution given by Jens and find it's a nice one. The problem with that solution is that the required font Times-Roman is actually missing from the Type1 Mathematica folder. So I just wanted to share a workaround I found. It's very simple.

  1. Open your pdf in Adobe Illustrator, hit OK when proposed to use a substitute font.
  2. Go to the Type->Find Font menu in Adobe Illustrator.
  3. Choose the missing Times font in the top part of the window.
  4. Replace with, choose System
  5. In the big list choose Times New Roman or similar.
  6. Hit Change all.

The result I get is practically indistinguishable from the original pdf, and all the text is on its place, that means no onverlaps which may happen if using the default substitute font.

Hope it helps.


Not the answer you're looking for? Browse other questions tagged or ask your own question.