4
$\begingroup$

For parallel computing, the window Parallel Kernel Status shows some information on the subkernels. I can use two kernels, and which each of them I can do parallel computations. However, it seems that Parallel Kernel Status (now?) only can be used for the kernel Local.

Could someone please verify the following behaviour? I am running version 10.0.2 32 bits on Windows 7.

Open a new notebook, set the notebook's kernel to Local2 and save the empty notebook. Start a new Mathematica session, open this empty notebook and open, by using the evaluation menu, Parallel Kernel Status. For all available subkernels, continuously error messages are generated:

Part::pkspec1: The expression ParallelStatusPrivate`remoteColumns cannot be used as a part specification.

Close Parallel Kernel Status, set the notebook's kernel to Local, open Parallel Kernel Status (it works now!) and close Parallel Kernel Status. Set the notebook's kernel back to the orignal value Local2 and evaluate the following commands:

LaunchKernels[]
CloseKernels[]
LaunchKernels[]

Now open Parallel Kernel Status again. It works! But it does not show the subkernels that are shown in the notebook.

The explanation could be the following. When, in a fresh Mathematica session, we use a notebook with kernel Local2, Parallel Kernel Status does not start up because of the kernel Local has not yet started up. When the kernel Local has been used, Parallel Kernel Status will show the subkernels for Local, whether or not in the notebook we are using this kernel or another.

Would this behaviour be as intended?

$\endgroup$
  • $\begingroup$ Yes, I receive the same error messages from Parallel Kernel Status under the conditions you describe with MMA version 10.0.2 64 bits on Windows 8.1. By the way, I often perform parallel computations with a kernel named other than local without difficulties, so I presume that the issue is isolated to Parallel Kernel Status. $\endgroup$ – bbgodfrey Dec 15 '14 at 15:23
  • $\begingroup$ @bbgodfrey Thanks for your confirmation. And yes, it has nothing to do with parallel computing as such, that works on any kernel. $\endgroup$ – Fred Simons Dec 15 '14 at 15:58
  • $\begingroup$ Same here, using 10.0.2 64-bit on Yosemite. $\endgroup$ – Taiki Mar 16 '15 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.