9
$\begingroup$

I have this local debug window that is so annoying

enter image description here

How can I hide it? What is the purpose of it?

$\endgroup$

migrated from mathematica.meta.stackexchange.com Jun 14 '12 at 14:12

This question came from our discussion, support, and feature requests site for users of Wolfram Mathematica.

  • 2
    $\begingroup$ Yes, you can. As a general rule, when dealing with frontend questions don't forget to specify your version and platform $\endgroup$ – Dr. belisarius Jun 14 '12 at 13:32
  • 3
    $\begingroup$ You can turn it on/off with the menu entry Evaluation > Debugger $\endgroup$ – Heike Jun 14 '12 at 13:34
  • $\begingroup$ @BrettChampion I wasn't paying attention and answered without realising that we're on meta. $\endgroup$ – Heike Jun 14 '12 at 13:41
  • 1
    $\begingroup$ @Rojo I don't like islands :) $\endgroup$ – Dr. belisarius Jun 14 '12 at 14:20
  • 1
    $\begingroup$ Easier to mistype than to misprintscreen $\endgroup$ – Rojo Jun 14 '12 at 15:22
8
$\begingroup$

1. You may turn off this menu selection:

enter image description here

(Or uncheck Debugger to turn off the entire apparatus.)

2. The tools are:

Mathematica graphics


Version 10 bugs

Mathematica 10 (and later) seems to have some strange problems regarding the debugger tools window. In 10.0 and 10.1 under Windows once I turn on the debugger I experience the window persisting even after the menu is unchecked; it reappears when I close a Notebook window. I suspect this has to do with the change to individual window menus rather than a menu bar. Fortunately in my case restarting Mathematica removes the tools window, however other people have experienced it persisting between sessions; see:

$\endgroup$
  • $\begingroup$ What about the second part " What is the purpose of it?":) $\endgroup$ – Ajasja Jun 14 '12 at 14:21
  • $\begingroup$ @Ajasja okay, updated; If you want to present a lecture on the use of a debugger be my guest. :^) $\endgroup$ – Mr.Wizard Jun 14 '12 at 14:38
  • $\begingroup$ didn't work for me :( stoopid thing still there ... any other suggestions? $\endgroup$ – Raksha May 14 '15 at 17:38
  • $\begingroup$ @Solarmew Are you using version 10? I have experienced weird behavior with the debugger window in 10/10.1. Once it is turned on in a session it seems to keep popping back up even when Debugger is unchecked. However after I restart Mathematica it does not reappear. $\endgroup$ – Mr.Wizard May 15 '15 at 1:24
  • $\begingroup$ I tried restarting it, but it came back XD ... But ctrl+shirt starting it worked :] $\endgroup$ – Raksha May 15 '15 at 2:36
1
$\begingroup$

In version 10, we need to Evaluation->Quit Kernel and then Start Kernel to prevent the debugger tool window from reappear.

$\endgroup$
  • 1
    $\begingroup$ Doesn't toggling Evaluation -> Debugger work? It works for me in 10.0, 10.3 and 10.4. What 10.x version do you have? $\endgroup$ – Szabolcs Jun 16 '16 at 15:58
  • $\begingroup$ No, toggling Evaluation -> Debugger will not prevent the debugger tool window from reappear if you open a new nb file, my version is 10.4.1 and 10.3.1 $\endgroup$ – Frank Jun 17 '16 at 17:50
  • $\begingroup$ Strange, it doesn't happen on my system. Maybe it's time to reset the front end (hold Ctrl-Shift or Command-Shift during startup)? I have the same two versions on OS X. $\endgroup$ – Szabolcs Jun 17 '16 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.