8
$\begingroup$

Bug introduced in 10.0.1 and fixed in 11.0.1


Consider this

Plot[Cos[π x]^2, {x, -0.5, 7.5}, PlotRange -> All, Frame -> False,
  Axes -> {True, False}, Ticks -> {Range[0, 7, 1], None}]

enter image description here

why is the tick "2" missing? Does the character "2" have a different size compared to other characters? Is this a bug?

I'm using version 10.0.1 on OS X 10.10.1

enter image description here

$\endgroup$
  • $\begingroup$ I cannot reproduce this behavior running v10.0.1 on OS X 10.10.1 on my MacBook Pro (mid 2014) or my MacBook Air (late 2010). $\endgroup$ – Bob Hanlon Dec 8 '14 at 23:11
  • 1
    $\begingroup$ it works ok on windows 7, 10.01 !Mathematica graphics $\endgroup$ – Nasser Dec 8 '14 at 23:32
  • 3
    $\begingroup$ OK, I could reproduce this behaviour with Mma 10.0.1 on OS X 10.9.5. Actually, there is no problem for me when the graphic is first displayed at its default size (360x227) but the "2" disappear when I resize manually the graphic to a smaller size (no problem for larger sizes than the default one) $\endgroup$ – SquareOne Dec 9 '14 at 0:26
  • 1
    $\begingroup$ The problem occurs also if I remove the Ticks option. It seems the problem comes only from the setting Axes->{True,False}. When I set this to Axes->{True,True} there is no more problem. $\endgroup$ – SquareOne Dec 9 '14 at 0:33
  • 1
    $\begingroup$ @xavier It's fixed in version 11. $\endgroup$ – xslittlegrass Nov 12 '16 at 3:53
1
$\begingroup$

Try:

Ticks -> {Range[0, 7, 1], Automatic}

Otherwise, I think Mathematica might be considering the point x = 2 on your graph as the origin of the , and from the Function Navigator, Possible Issues of Ticks states that it will not label the origin.

Switch to Axes->{True,True} and post the screenshot.

Also, removing PlotRange -> All might do the trick since it is redundant (Ticks sort of handles PlotRange's meaning in this graph)

$\endgroup$
  • 1
    $\begingroup$ Unfortunately it does not fix the problem (v.10.0.2 OS X 10.9.5) $\endgroup$ – SquareOne Jan 12 '15 at 0:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.