21
$\begingroup$

I exported a web-embeddable CDF, and created an html page with the automatically generated code. Both are in a local folder. When I open the HTML page in a Chrome browser, i get the PNG image telling me to download the Plugin. But I already have it, and indeed downloading again does not fix the problem. I then went to several CDF files that I have uploaded to server, and that worked in the past, and none of them work. However, all work in Safari. What has changed?

I suspect this may have to do with Chrome blocking certain plugins, but I do not see CDF in the list at chrome://plugins

On my local machine I am running Mma 10.0.1, under Mac OS 10.9.5. Chrome is Version 39.0.2171.71 (64-bit).

$\endgroup$
  • 1
    $\begingroup$ Yes, this has stopped working a while ago in Chrome on my OS X machine as well (Wolfram Demonstrations don't work either). It's not just your computer. It works in other browsers. I assumed it had to do with Chrome phasing out NPAPI support, but maybe I'm wrong. Since this problem is not specific to your setup, and it's likely to impact the Wolfram Demonstrations site, I'd suggest contacting Wolfram support directly with this problem. $\endgroup$ – Szabolcs Dec 7 '14 at 17:53
  • $\begingroup$ I saw that I had the same problem in my Windows 8.1 machine. Then I also saw there were some unwanted add-ons (advertising) that must have crept in. Disabling them, restarting Chrome and enabling plugins for demonstrations.wolfram.com seems to have solved the problem. But maybe that doesn't work in OS X machines. $\endgroup$ – Luca M Dec 7 '14 at 19:09
  • $\begingroup$ Not strictly related but interesting cdf v.10 post. (see the last replies) $\endgroup$ – SquareOne Dec 7 '14 at 23:08
  • $\begingroup$ Might as well learn javascript at this point … $\endgroup$ – isomorphismes Mar 21 '17 at 19:46
18
$\begingroup$

I had contacted tech support at Wolfram about one of my demonstrations, and got a reply from Ed Pegg (one of the editors at the Wolfram Demonstration site) which included this:

"Mathematica 10 turned out to be incompatible with the server our Demonstration site runs on, so we're needing to do a major upgrade. But it's taking longer than expected. The landscape for plugins is changing -- Chrome soon won't accept 32-bit plugins. The process of making a free Version 10 player is proving trickier than expected."

I guess from this that the cdf player must be a 32-bit plugin, and is now rendered incompatible with Chrome. As Szabolcs points out, the cdf player continues to work in other browsers like Firefox and Safari.

$\endgroup$
  • $\begingroup$ Thanks for contacting them, and reporting back. It's good to get verification that it's not just a bug on my end. I was guessing that Chrome's switch to 64-bit might be involved. $\endgroup$ – Joe Fusion Dec 12 '14 at 3:48
  • $\begingroup$ @bills Do you know whether the Mathematica team has solved the problem? My cdfs do not run for months $\endgroup$ – Jjm Aug 5 '15 at 17:28
  • 1
    $\begingroup$ Yes thank you for this reply. Wolfram alpha pro still prompts for cdf player in Chrome - and then ignores it after you go to the trouble of downloading it. I won't be holding my breath. I am getting more than a little annoyed at these browser wars in the face of more global standards such as HTML5 and so on. I now need three different browsers on my machine to handle various sites that are incompatible with one or t'other. $\endgroup$ – Jeltz Sep 12 '15 at 3:57
5
$\begingroup$

As an update, I received this message from Wolfram support in December 2015:

"Just to let you know, web browsers are slowly moving away from the technology that supports our plugin. You may have noticed that it does not work on Chrome and Edge, and more browsers are to follow over the next year or so. We are migrating most of the functionality offered through the plugin over to our Wolfram Cloud products.

In short, as plugins are a dying technology, our development teams are moving away from updating it. You can read more about it here:

http://support.wolfram.com/kb/20057"

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.