4
$\begingroup$

Almost every morning, when I start my work, I observe the same problem as already mentioned here: Using Datasets in Mathematica 10.0 and here: Dataset: cannot reproduce a basic example. A bug?

I opend this new thread, since I can't comment the above mentioned topics because I'm still a newbie (in the forum and with Mathematica).

It doesn't matter whether I'm using my own Dataset or one of the mentioned examples. I always get the same result: "An unknown box name (TypeSystem TypeMap) was sent as the BoxForm for the expression. Check the format rules for the expression." And I get it in all my .nb files.

My own Dataset is coming from an OracleDB and the used syntax looks like this:

`hprdb = SQLSelect[dbconnection, "TABLE", {"ID", "VAL_1", "VAL_2",  "VAL_3"},
 "ShowColumnHeadings" -> True]`

`hprds = Dataset[AssociationThread[First@ hprdb, #] & /@ Rest@ hprdb]` 

I'm using Ubuntu 14.04 (64-bit) and Mathematica 10.0.1

The only way to overcome the problem is to start and stop the kernel, exit and open Mathematica several times and then after many tries (> 5 minutes) it suddenly works again. When it eventually worked once, it works in all .nb files.

Any ideas how to overcome this strange behavior, since it is really annoying?

$\endgroup$
  • $\begingroup$ Can you post your Dataset and the operation that exhibits the problem? $\endgroup$ – Ymareth Nov 17 '14 at 9:00
  • $\begingroup$ I added the syntax for my own Dataset, where the last line fails with the above mentioned error message. But if I'm using the examples from the linked threads I get exactly the same results. $\endgroup$ – Lea Nov 17 '14 at 9:18
  • $\begingroup$ Try a clean start and also delete the FrontEnd cache (see here). $\endgroup$ – Alexey Popkov Nov 17 '14 at 10:51
  • $\begingroup$ First I tried a clean start, which didn't help. Then I deleted the $BaseDirectory and $UserBaseDirectory as described in the second link. This destroyed my DB-setup, which I had to reset. But it also didn't help. Then I started with a clean start a new .nb with only the line titanic = ExampleData[{"Dataset", "Titanic"}]. This worked in the second try... but I don't know why. As observed before, everything elese works now again. It is a workaround, but a very non-satisfying one. $\endgroup$ – Lea Nov 18 '14 at 8:45
  • $\begingroup$ When you say "This worked in the second try" do you mean it only works the second time you execute the offending line (i.e. repeatedly fails executing the first time but works the second) OR the second time you started afresh it worked and continues to work? $\endgroup$ – Ymareth Nov 18 '14 at 9:37
1
$\begingroup$

It is only a workaround, but I found a way which works reproducible:

I start Mathematica merely with mathematica -cleanstart. Whenever the in the question mentioned behavior occurs, I exit Mathematica, restart and open a .nb which contains only the line

titanic = ExampleData[{"Dataset", "Titanic"}]

After evaluation of this example, I'm able to evaluate my Datasets without any further trouble.

I don't know, why this works, but this workaround saves a lot of time and frustration.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.