4
$\begingroup$

I draw a plot using ListPlot. But I noticed that PlotMarkers are 'covered' by the axes; see example below:

enter image description here

I was trying to use the option Method -> {"AxesInFront" -> False} but it does not help. Below is my full code of this plot. The size of markers has to be as set.

ListPlot[{list1, list2},
 PlotStyle -> Directive[AbsolutePointSize[60]],
 GridLines -> Automatic, 
 GridLinesStyle -> Directive[Gray, Dashed],
 Frame -> {True, True, False, False},
 FrameLabel -> {"Number of non-zero bits", "alpha"},
 Axes -> False,
 LegendShadow -> None,
 LegendSize -> 0.5,
 PlotLegend -> {Style["exact value", FontFamily -> "Helvetica", 130], 
   Style["estimated value", FontFamily -> "Helvetica", 130]},
 LegendPosition -> {0.10, 0.10},
 PlotRange -> {0, 20},
 ImageSize -> 7000,
 Method -> {"AxesInFront" -> False}]

Solution suggested by evanb: enter image description here

$\endgroup$
7
$\begingroup$

I believe you're looking for the option

PlotRangeClipping -> False
$\endgroup$
  • 1
    $\begingroup$ Nice answer. Two Plots showing how it works (before vs. after) would be great. $\endgroup$ – Dr. belisarius Nov 10 '14 at 20:07
  • 1
    $\begingroup$ I think the question relies on the PlotLegends package, which is deprecated, and also on list1 and list2 which I didn't want to futz around with / make up. Hence the lack of pictures :) $\endgroup$ – evanb Nov 10 '14 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.