2
$\begingroup$

I just installed webMathematica on Linux Debian + Tomcat7 + Mathematica 9.0.

I'm getting this error web testing any example.

HTTP 403 - MathLink linkname missing or malformed.

The error is also written in webMathematica.log

My MSPConfiguration file is :

<MSPConfiguration>
 <KernelPool>
  <KernelPoolName>General</KernelPoolName>
  <KernelExecutable>/usr/local/Wolfram/Mathematica/9.0/Executables/MathKernel</KernelExecutable>
  <KernelNumber>1</KernelNumber>
  <URLPattern>/*</URLPattern>
 </KernelPool>
</MSPConfiguration>

The kernel is running well individually, I can evaluate expressions as I want.

EDIT: I added a user tomcat which can run the kernel as well. I also added the path to mathpass and set the JLinkNativeLibraryDirectory tag.

EDIT: If I set any non existing directory in KernelExecutable tag, the error is the same.

  • Kernel ID : 1
  • State DESTROYED
  • Error Text MathLink linkname missing or malformed.
  • Error Type MATHLINKEXCEPTION

Do you have some idea ?

$\endgroup$
3
  • $\begingroup$ You state that the kernel works fine, but have you tried logging into you machine as the tomcat user and launching the kernel? If that works, then you could try specifying more configuration settings, like <JLinkNativeLibraryDirectory> or <KernelLaunchFlags> (for location of mathpass). $\endgroup$
    – ChadK
    Nov 7, 2014 at 15:17
  • $\begingroup$ Tomcat user has permissions (sudo -u tomcat math works - How can I check ?) and I added both tag, restart tomcat and nothing changed. I have tried to put a bad kernelexecutable path, and the error is the same. $\endgroup$
    – Crypto
    Nov 10, 2014 at 8:44
  • $\begingroup$ Try checking permissions with su tomcat rather than sudo -u. Then try to run the MathKernel with path as shown in the KernelExecutable tag. If that doesn't help, I'd contact Wolfram. $\endgroup$
    – ChadK
    Nov 10, 2014 at 15:25

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.