9
$\begingroup$

I have a foreign language keyboard (French). Most of my programs recognize the my French keyboard, except Mathematica, which behaves as if the keyboard were English. So far I haven't found any way to change this.

Unfortunately, French and English keyboards are significantly different. For example, the non-letter keys have basically no overlap--it took me about 10 minutes to find the colon key.

Does anyone know how to get Mathematica to recognize a non-English keyboard?


Edit: Operating system is Windows 7.

$\endgroup$
  • 1
    $\begingroup$ I guess the name of your operating system might be relevant. $\endgroup$ – Coolwater Oct 12 '14 at 12:36
  • $\begingroup$ Okay, duh. Sorry about that. Windows 7. $\endgroup$ – quantum_loser Oct 12 '14 at 12:45
  • $\begingroup$ I hope you find a solution to this problem. In any case I recommend you to get a second keyboard just for programming with an American English layout. Not only for the easy access to all those characters needed for programming but also to get keyboard shortcuts that make sense in most programming tools. $\endgroup$ – Gustavo Delfino Aug 26 '15 at 13:48
2
$\begingroup$

Since version 5, WRI has provided a French Language Kit for Mathematica. This is an add-on which adds French documentation, user interface, and spell checking.

If you download and install the linked package, you should be able to set Mathematica to use French in the Preferences dialog.

Additionally, make sure your keyboard layout is set to the use the proper keymap for your (French) keyboard. Here are instructions for changing keymaps in Windows.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.