14
$\begingroup$

Bug introduced in 10.0.1 and fixed in 10.0.2 -- appears to affect Linux only.


It has been really strange for me. I am not sure it's regression after v10.0.1, or something went wrong with my system. After running this simple code

b = Plot[x, {x, 0, 10}, Frame -> True, PlotStyle -> Dashed]

my Mathematica window becomes

enter image description here

Edit:

(1) Just re-installed v9.0.1, there is no such problem on v9.0.1. So it is regression.

(2) Seen from comments/answers, Windows and Mac do not have this problem, but problem under Linux is confirmed.

(3) The problem is already in Graphics (which is more fundamental). For example,

Graphics[{Dashed, Circle[]}]

has the same problem.

$\endgroup$
  • 1
    $\begingroup$ I don't notice this on Windows, so it's probably a system dependent bug. $\endgroup$ – RunnyKine Oct 1 '14 at 7:19
  • $\begingroup$ No problem on windows using 10.01, screen shot !Mathematica graphics $\endgroup$ – Nasser Oct 1 '14 at 7:23
  • 2
    $\begingroup$ The same problem in Ubuntu + 10.0.1 . Moreover, no such behavior observed in 10.0. Seriously, this is not user-friendly. $\endgroup$ – Alexey Bobrick Oct 1 '14 at 12:54
  • 2
    $\begingroup$ @halirutan confirmed that it was reproducible on our end, and I believe a fix is in the next version. $\endgroup$ – rcollyer Nov 7 '14 at 13:05
  • 1
    $\begingroup$ Indeed, it's fixed in 10.0.2. Finally I don't have to reopen the files in M9 to make plots :) $\endgroup$ – Yi Wang Dec 11 '14 at 17:07
8
$\begingroup$

I am having a same problem on Linux, Mathematica 10.0.01. My "solution" (if you are looking for it?) for dashing of the frame was to specify each frame part individually:

b = Plot[{x, x^2}, {x, 0, 10}, Frame -> True,
   FrameStyle -> {{Dashing[1], Dashing[1]}, {Dashing[1], Dashing[1]}}, PlotTheme -> "Monochrome"]

enter image description here

Very annoyingly, if I try to do the same trick to fill plot lines, one of them gets "cut"

b = Plot[{x, x^2}, {x, 0, 10}, Frame -> True,
   FrameStyle -> {{Dashing[1], Dashing[1]}, {Dashing[1], Dashing[1]}},
   PlotStyle -> {Dashing[1], Dashing[1]}, PlotTheme -> "Monochrome"]

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Nice, thanks! On my computer this option can be simplified into FrameStyle -> Dashing[1]. Also, if you specify PlotStyle->Dashing[2], you will not get cut. I think the cut is actually the dashing :) $\endgroup$ – Yi Wang Oct 2 '14 at 14:36
  • 1
    $\begingroup$ Also note that solid line means Dashing[{}], so had better not use Dashing[1] or Dashing[2] (otherwise it cuts after the line is long enough). $\endgroup$ – Yi Wang Oct 2 '14 at 14:49
6
$\begingroup$

I'm expanding my comment to show I get the same problem, on V10.0.1 on Ubuntu 12.04 LTS.

I can also repeat it like this:

b = Plot[{x, x^2}, {x, 0, 10}, Frame -> True, PlotTheme -> "Monochrome"]

And you can see the dashing in the cells down the right-hand side, as well as the dashed frame.

enter image description here

What is then weirder is if you click on the graph, this happens:

enter image description here

The line that was solid is now dashed too!

$\endgroup$
  • 1
    $\begingroup$ Thanks for confirmation! Has reported bug to Wolfram. $\endgroup$ – Yi Wang Oct 1 '14 at 8:17
  • 1
    $\begingroup$ Yes, also, if you remove/fold the plot, then fold mathematica window, switch to another window and unfold it back again, the dashes disappear, unless you unfold the plot. $\endgroup$ – Alexey Bobrick Nov 7 '14 at 12:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.