23
$\begingroup$

Alright, maybe I'm just really stupid. But I tried my damnedest to get rid of this stupid toolbar. I checked every menu and searched google for a solid 20 minutes. Eventually, I just copied the code from the file this menu effectively ruined and pasted it in a new file, and saved it as the old file's name.

I'm speaking of this beast:

enter image description here

There's no little x to close it. Strangely, I easily found out how you can turn it on (though I should point out, I positively didn't click this, so I'm guessing some random keystroke that happens to be the hotkey for it must have opened it...); to turn it on, go to Window -> Toolbar -> Templating. It'll pop up, but if you click it again, I get a window that says "Untitled.nb is already a Template notebook". However, for whatever reason, if I click "Formatting" (right above Templating) instead, it puts a formatting bar right above the templating bar, but if I go back, a check is there (next to formatting), and clicking it again turns the formatting bar off.

I really hope this is a rare bug, because I can't imagine a normally so well designed program would have some truly awful UX flaw like this. Thank you.

$\endgroup$
  • 1
    $\begingroup$ It's a nasty bug. I've run into it, too. What you did -- saving your work into a new notebook -- is the only work-around I know. $\endgroup$ – m_goldberg Oct 1 '14 at 4:52
  • $\begingroup$ @m_goldberg, wow, okay, at least I feel a little better because it means there wasn't an obvious fix right in front of me. But that is RIDICULOUS! They JUST came out with a new version. Did they honestly just not try this once? It seems like you might want to at least try clicking on everything in the main toolbars once before you release new software. Arrrgh. $\endgroup$ – F dot Floss Oct 1 '14 at 14:16
  • $\begingroup$ I've been running into this issue as well, but it seems to happen spontaneously, even to notebooks that I've copied out. (Add this to the dozens of times over the last few days that I've had shortcuts trigger the activation or new workbook dialogs, and I'm really starting to regret the money I just spent on this. I didn't realize I'd be doing QA. >:( $\endgroup$ – Eight Hour Lunch Oct 2 '14 at 1:16
27
$\begingroup$

The TemplateNotebook header is a docked cell, and you can remove it by removing that docked cell:

SetOptions[EvaluationNotebook[], DockedCells -> {}]

(there should certainly be an option to remove it, but this will avoid you having to re-create the notebook on your own).

$\endgroup$
  • $\begingroup$ Thank you! Wow, what an obnoxious bug. I actually found another reproducible one this morning, is there a common way to file them? $\endgroup$ – F dot Floss Oct 1 '14 at 21:40
  • $\begingroup$ the best way is generally to e-mail technical support(support@wolfram.com) and they should be able to file them, and inform you about any possible work-arounds. $\endgroup$ – Nick Lariviere Oct 6 '14 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.