9
$\begingroup$

So I'm putting in some function, busy typing away. Then after I've entered some text, I pause for a few seconds. In this time, the notebook pops up the question "Convert to Free-Form Linguistic Input," like this:

enter image description here

It is already highlighted such that if I hit Enter it will go ahead and do this conversion, deleting a large chunk of what I've already typed and replacing it with something useless. (edit to add: This cannot be undone through the Undo menu option!!!)

Now I love some of the interface improvements to the newer versions of Mathematica. Specifically, I love how it will bring up a list of pre-defined functions and variables while I'm typing. That has saved me much time. But I can't ever see a situation where I would want to use free-form linguistic input. I'm not sure exactly what it is, but I know I don't want it. How can I disable this? I already disabled the "Suggestion Bar".

I'm using version 10.0 on Linux.

$\endgroup$
8
$\begingroup$

Most likely you want to disable the "Enable natural language detection". This is in the same list in the preferences as the "Suggestion Bar" setting.

$\endgroup$
  • 1
    $\begingroup$ @JasonB No problem. You also could try to write more cryptic function names like f3q904m[x$001a_]:=... to prevent that Mathematica believes it could help you with natural language :-) $\endgroup$ – halirutan Sep 17 '14 at 13:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.