-1
$\begingroup$

I've encountered a strange problem with V10. I can't quite nail it down, but the Solve seems to be unable to solve equations that it could in previous versions. Here is one I'm almost positive I've done before.

Solve[q == l^a ((l w b)/(r a))^b, l]

For those who are wondering this is one of the steps in solving for a cost function using a Cobb–Douglas production function. It can obviously be solved, all Mathematica has to do is group the exponents.

Is there a change in the solve assumptions, options? I've also tried being explicit about reals and allowing inverse functions.

$\endgroup$
  • $\begingroup$ For the example you give, V9 behaves exactly the same as V10. $\endgroup$ – m_goldberg Sep 13 '14 at 2:38
1
$\begingroup$

Did you try

Solve[q == l^(a + b) ((w b)/(r a))^b // PowerExpand, l]

Solve::ifun: Inverse functions are being used by Solve, so some solutions may not be found; use Reduce for complete solution information. >>

{{l -> (a^b b^-b q r^b w^-b)^(1/(a + b))}}
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.