I work in an environment that has mathematica's internet connectivity turned off under Help > Internet Connectivity. Recently, after installing mathematica 10.0, every time mathematica is loaded it complains about internet connectivity and put up messages saying

PacletInstall::offline: The Wolfram System cannot install paclet WolframAutoUpdate because it is currently configured not to use the Internet for paclet downloads. To allow internet access, use Help > Internet Connectivity....

is there a way to disable such alerts/disable the auto update?

  • $\begingroup$ Have you tried Off? $\endgroup$ – Dr. belisarius Aug 29 '14 at 4:57
  • $\begingroup$ @belisarius this message is printed right after mathematica is launched, before I've entered anything, so Off does not apply here. $\endgroup$ – egwene sedai Aug 29 '14 at 5:04
  • 4
    $\begingroup$ I can't seem to reproduce this problem so I can't test a solution, but try putting Off[PacletInstall::offline] in your kernel/init.m file; it may load soon enough to have effect. $\endgroup$ – Mr.Wizard Aug 29 '14 at 11:38
  • $\begingroup$ I don't know if it matters, but what OS are you using? $\endgroup$ – Kellen Myers Aug 31 '14 at 17:31
  • $\begingroup$ @KellenMyers I'm on windows, current I resort to setting a dummy proxy that goes no where to temporarily fix this warning. $\endgroup$ – egwene sedai Sep 1 '14 at 3:01

It is correct! Follow these steps:

  1. Enable Internet Connectivity in Preferences.
  2. Allow automatic updates.
  3. Restart Mathematica.
  4. Disable Internet.
  5. Restart Mathematica.

Et Voila'!

  • $\begingroup$ It wasn't me but you get downvote, probably, because it does exactly the oposite that OP want's. At least this is my interpretation, so: OP needs Internet while wants I Conn to be false. $\endgroup$ – Kuba Dec 18 '14 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.