1
$\begingroup$

Situation:


In:= w = WordData[];
During eval of In:= ReplaceAll::reps: {Expression/. Null} is neither a list of replacement rules nor a valid dispatch table, and so cannot be used for replacing.[>>][1]
During eval of In:= LinkOpen::linke: Specified file is not a MathLink executable..[>>][2]
In:= WordData["Day", "Definitions"] Out:= WordData["Day", "Definitions"]
(*last seems unevaluated...*)
In:= Here Out:= Missing[NotAvailable]


Intention:

I am simply calling this function to use it but its not working.

  • I am connected to the internet and I am able to call WolframAlpha["query"] sucessfully...
  • Any idea that do not include acrobatics with the Mathematica File System is more than welcome...
  • I already check my firewall settings ...

Here is another one:


In:=  CountryData[]
Out:=  DataPaclets`CountryDataDump`$GroupHash["Countries"]
  • Any ideas...?

System Info:


~$uname -a
Linux ***** 3.16.1-1-ARCH #1 SMP PREEMPT Thu Aug 14 07:40:19 CEST 2014 x86_64 GNU/Linux


Network information:


In[2]:= SystemInformation["Network"] //Column                                   

Out[2]:= IPAddresses -> {fe80::****:274c:a7c7:***, 192.168.1.145}
        AllowInternetUse -> True
        LoadOnDemand -> True
        LoadOnDemandServers -> {http://pacletserver.wolfram.com}
        LatestTransaction -> Missing[NotActive]
        LatestTransactionServer -> Missing[NotActive]
        LastLocalIndexUpdate -> {2014, 8, 28, 19, 11, 30.766294}
        LastLocalIndexUpdateServer -> {}
        Paclets -> PacletManager Version 2.2.0
        TotalDownloads -> Missing[NotActive]
        DownloadsDirectory -> Missing[NotActive]

Mathematica Kernel Information:


In[3]:= SystemInformation["Kernel"] //Column                                    

Out[3]:= Version -> 10.0 for Linux x86 (64-bit) (June 29, 2014)
        ReleaseID -> 10.0.0.0 (5098646, 5098517)
        LicenseID -> *****-****
        PatchLevel -> 0
        ActivationKey -> ****-9190-****
        ActivationGroupID -> *****-****
        MachineID -> 6539-*****-01360
        UserName -> *****
        MachineName -> ****
        MachineDomains -> {sd.cox.net}
        LicenseServer -> gabriel
        MaxLicenseProcesses -> Infinity
        LicenseExpirationDate -> {Infinity, 0, 0, 0, 0, 0}
        MachineType -> PC
        OperatingSystem -> Unix
        ProcessorType -> x86-64
        Language -> English
        CharacterEncoding -> UTF-8
        SystemCharacterEncoding -> UTF-8
        TimeZone -> -7.
        CreationDate -> DateObject[{2014, 6, 29}, TimeObject[{19, 7, 59}]]
        InstallationDirectory -> /usr/local/Wolfram/Mathematica/10.0
        WSTPVersion -> 4.25 (2014062701)
        ProcessorCount -> 2
        LicenseSubprocesses -> 1
        MaxLicenseSubprocesses -> Infinity

I also tried Trace and TracePrint on the WordData[] function call. Nothing clear so far ...


This is a link to the output of:

System`Dump`AutoLoad[Hold[CountryData], Hold[CountryData], "DataPaclets`CountryData`"] // TracePrint


Wolfram Documentation:

ReplaceAll::reps error docs.

LinkOpen::linke error docs.

$\endgroup$
  • $\begingroup$ Please include the details of your system, e.g. Mathematica version, platform, etc. $\endgroup$ – Mr.Wizard Aug 29 '14 at 2:19
  • 1
    $\begingroup$ Possibly related: (29216), (39110). No solutions there, unfortunately. $\endgroup$ – Mr.Wizard Aug 29 '14 at 2:23
  • $\begingroup$ Thank you @Mr.Wizard I will take a closer look to this issue later on... I will post here the response from wolfram support... thanks... $\endgroup$ – Schopenhauer Aug 29 '14 at 3:54
1
$\begingroup$

I can't Trace the WordData problem because I don't have that error on my system. Howvever after loading CountryData[] you should have this behavior:

DataPaclets`CountryDataDump`$GroupHash["Countries"] // Short
{Afghanistan, Albania, Algeria, AmericanSamoa, << 233 >>, Yemen, Zambia, Zimbabwe}

That you do not indicates that this definition was never properly loaded.

The definition of CountryData on my system, before using CountryData[]:

CountryData := 
 System`Dump`AutoLoad[Hold[CountryData], Hold[CountryData], "DataPaclets`CountryData`"] /;
   System`Dump`TestLoad

You should first check to see that System`Dump`TestLoad returns True:

System`Dump`TestLoad
True

Next, please check and report the output of this:

mx = System`Private`$SystemFileDir <> System`Dump`fixfile["DataPaclets`CountryData`"] <> "x"

FileByteCount[mx]

On my machine:

"C:\\Program Files\\Wolfram \
Research\\Mathematica\\10.0\\SystemFiles\\Kernel\\SystemResources\\Windows-x86-64\\\
DataPaclets\\CountryData.mx"

10532
$\endgroup$
  • $\begingroup$ @Schopenhauer Okay, next check added to my "answer." $\endgroup$ – Mr.Wizard Aug 29 '14 at 4:35
  • $\begingroup$ I guess there is no other way but to dive into the file system ... no luck still Out:= /usr/local/Wolfram/Mathematica/10.0/SystemFiles/Kernel/SystemResources/Linux-x86-64/DataPaclets/CountryData.mx In:=FileByteCount[mx] Out:= 10626 << "/usr/local/Wolfram/Mathematica/10.0/SystemFiles/Kernel/\ SystemResources/Linux-x86-64/DataPaclets/CountryData.mx" In:= CountryData[] Out:= DataPaclets`CountryDataDump`$GroupHash["Countries"] $\endgroup$ – Schopenhauer Aug 29 '14 at 6:43
  • 1
    $\begingroup$ @Schopenhauer Please include the full output of System`Dump`AutoLoad[Hold[CountryData], Hold[CountryData], "DataPaclets`CountryData`"] // TracePrint in your Question. (Run the command in a fresh kernel.) $\endgroup$ – Mr.Wizard Aug 29 '14 at 8:11
  • $\begingroup$ Here is the output of: System`Dump`AutoLoad[Hold[CountryData], Hold[CountryData], "DataPaclets`CountryData`"] // TracePrint $\endgroup$ – Schopenhauer Aug 29 '14 at 18:59
0
$\begingroup$

Solution (This solution worked for my particular case.)

Install Mathematica 9 alongside with Mathematica 10 then reinstall Mathematica 10

  • I have no idea why it worked. I do not have enough time now to find out. I will appreciate any comments for a further research of an answer...

  • If you use Arch Linux install tree with:

    $ sudo pacman -S tree
    The purpose of this is to see clearly the structure of your installation directory.

  • This the output of the tree program after cd into the $InstallationDirectory

    $ tree -af </code></pre> Oops... the output of the `tree` program on the `$InstallationDirectoryis about <em>60,000 lines...</em> In simple terms I installed both versions of Mathematica and the issue with theIn1:= WordData[ ]` call was gone.

  • Mathematica 10 lives now on /usr/local/Wolfram/Mathematica/10.0/ and Mathematica 9 on /usr/local/Wolfram/Mathematica/9.0/ ...

  • Here is a screenshot of a happy ending... enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.