8
$\begingroup$

My Workbench runs perfectly using Mathematica 9, however simple things which run just using the Mathematica 10 front end won't run when using Mathematica 10 and Workbench 2.

These simple two lines of code produce errors when workbench is used. Any insight would be much appreciated

Markus

ids = "C:/Mathematica/Data/";
rawdata = Import[ids <> "DATA8.XLS"][[1]]

LinkObject::linkn: Argument LinkObject["C:\Program Files\Wolfram Research\Mathematica\10.0\SystemFiles\Java\Windows-x86-64\bin\javaw" -classpath "C:\Program Files\Wolfram Research\[Ellipsis] wolfram.jlink.JLinkSystemClassLoader com.wolfram.jlink.Install -init "C:\Users\User\AppData\Local\Temp\m-38eb99ec-4611-4185-9090-ae0d23ac0ad9",183,8] in LinkReadyQ[LinkObject["C:\Program Files\Wolfram Research\Mathematica\10.0\SystemFiles\Java\Windows-x86-64\bin\javaw" -classpath "C:\Program Files\Wolfram Res[Ellipsis] m.jlink.JLinkSystemClassLoader com.wolfram.jlink.Install -init "C:\Users\User\AppData\Local\Temp\m-38eb99ec-4611-4185-9090-ae0d23ac0ad9",183,8]] has an invalid LinkObject number; the link may be closed. >>

LinkObject::linkn: Argument LinkObject["C:\Program Files\Wolfram Research\Mathematica\10.0\SystemFiles\Java\Windows-x86-64\bin\javaw" -classpath "C:\Program Files\Wolfram Research\[Ellipsis] wolfram.jlink.JLinkSystemClassLoader com.wolfram.jlink.Install -init "C:\Users\User\AppData\Local\Temp\m-38eb99ec-4611-4185-9090-ae0d23ac0ad9",183,8] in LinkConnectedQ[LinkObject["C:\Program Files\Wolfram Research\Mathematica\10.0\SystemFiles\Java\Windows-x86-64\bin\javaw" -classpath "C:\Program Files\Wolfram R[Ellipsis] jlink.JLinkSystemClassLoader com.wolfram.jlink.Install -init "C:\Users\User\AppData\Local\Temp\m-38eb99ec-4611-4185-9090-ae0d23ac0ad9",183,8]] has an invalid LinkObject number; the link may be closed. >>

LinkObject::linkn: Argument LinkObject["C:\Program Files\Wolfram Research\Mathematica\10.0\SystemFiles\Java\Windows-x86-64\bin\javaw" -classpath "C:\Program Files\Wolfram Research\[Ellipsis] wolfram.jlink.JLinkSystemClassLoader com.wolfram.jlink.Install -init "C:\Users\User\AppData\Local\Temp\m-38eb99ec-4611-4185-9090-ae0d23ac0ad9",183,8] in LinkReadyQ[LinkObject["C:\Program Files\Wolfram Research\Mathematica\10.0\SystemFiles\Java\Windows-x86-64\bin\javaw" -classpath "C:\Program Files\Wolfram Res[Ellipsis] m.jlink.JLinkSystemClassLoader com.wolfram.jlink.Install -init "C:\Users\User\AppData\Local\Temp\m-38eb99ec-4611-4185-9090-ae0d23ac0ad9",183,8]] has an invalid LinkObject number; the link may be closed. >>

$\endgroup$
  • 1
    $\begingroup$ I had a similar problem (on Linux though) and I reported it to WRI. They said a new version addressing this issue will be made available soon. $\endgroup$ – b.gates.you.know.what Aug 26 '14 at 13:56
  • $\begingroup$ @b.gatessucks a new version of...what? Workbench or Mathematica? $\endgroup$ – magma Sep 1 '14 at 22:36
  • $\begingroup$ @magma Workbench. $\endgroup$ – b.gates.you.know.what Sep 2 '14 at 6:59
  • 4
    $\begingroup$ @b.gatessucks well, let's hope so. A new version of WB is long overdue $\endgroup$ – magma Sep 2 '14 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.