24
$\begingroup$

So I have recently upgraded to a Windows ultrabook with a high resolution display. All my software seems to cope just fine with the high resolution, except for Mathematica 10. Mathematica seems to pretend the screen resolution is lower, and blurs both frontend text and graphics output.

How can I configure the interface to display crisp text?

$\endgroup$
  • $\begingroup$ Does this help? $\endgroup$ – mfvonh Aug 25 '14 at 5:37
  • 1
    $\begingroup$ Also, this seems to be closely related: (18419). I don't know if Mathematica 10 for Windows supports high-PPI displays. $\endgroup$ – Mr.Wizard Aug 25 '14 at 6:36
  • $\begingroup$ Actually there are many programs that have trouble with scaling on high resolution displays. At least Mathematica displays everything correctly and at a readable size, even if blurry. I don't believe there is a user-end solution here. We'll need to wait until Wolfram starts supporting high resolution displays on Windows. $\endgroup$ – Szabolcs Mar 12 '15 at 20:39
  • $\begingroup$ @Szabolcs Following the maxim of "don't answer in comments" perhaps you should post that properly? No other answer has been forthcoming. $\endgroup$ – Mr.Wizard Mar 12 '15 at 21:02
  • $\begingroup$ @Mr.Wizard While I don't believe that there's a user-end solution, but I might be wrong ... I've been away from Windows for quite a while until I bumped into the same problem recently. $\endgroup$ – Szabolcs Mar 12 '15 at 21:25
22
$\begingroup$

Mathematica 10 is not high-DPI-aware on Windows and so Windows renders it at the native resolution and then scales it by a factor of 2 by default to make it readable. Once Mathematica supports high-DPI displays in Windows, they will be able to properly render text and graphics that aren't blurry.

If you're running Windows 8.1, you can disable this default scaling of 2 for the application by right clicking on the Mathematica shortcut and going to "Properties" and then the "Compatibility" tab and check the box "Disable display scaling on high DPI settings." Once you do this and restart Mathematica, everything will be tiny but crisp and not blurry.

You can zoom by a factor of 2 by executing:

In[1]:= SetOptions[$FrontEnd, Magnification -> 2]

Doing the above will result in crisp plots and fonts that are a readable size and it should save between sessions and between notebooks. It's not nearly as nice as native awareness of high-DPI settings that Wolfram could implement, but it's a stopgap. It doesn't apply universally, so help windows are a bit of an nuisance etc.

$\endgroup$
  • $\begingroup$ On Mac, high DPI works natively. This setting helps out a bit on Windows as suggested, but e.g. the search bar in the Documentation Center will look awkward. $\endgroup$ – masterxilo Apr 28 '16 at 21:34
1
$\begingroup$

I had/have this issue on Win 10, Mathematica 11.2

My solution is:

  1. Make shortcut to the Mathematica on Desktop.

  2. Then right click the shortcut, Properties, Open Compatibility tab and set options Override high DPI scaling for Application like on the screenshot below.

  3. WORKED for me!

Settings for DPI compatibility

$\endgroup$
  • 1
    $\begingroup$ This does NOT work. You end up with tiny windows and interface elements, which is an issue that cannot be fully solved by fiddling with the Magnification setting as noted in Sydius' answer above. Bottom line, Mathematica is currently incompatible with high-DPI screens. $\endgroup$ – Pirx Dec 4 '17 at 11:59
  • $\begingroup$ @Prix: You are probably right about Mathematica 10. My claim is for current version 11.2. I have crystal clear text on my screen. $\endgroup$ – drgrujic Dec 5 '17 at 12:35
  • 1
    $\begingroup$ Sure you'll have crystal-clear text, but it's going to be tiny; which can be fixed by changing the magnification, at which point various interface elements (stuff like toolbar icons and such) will still be tiny. The same will be true for images in the help files, etc., etc. The situation in this respect is the exact same in the latest Mathematica version as it was in all versions before. The statement in my comment above stands. $\endgroup$ – Pirx Dec 6 '17 at 14:31

protected by M.R. Aug 30 '18 at 4:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.