0
$\begingroup$

I am getting the following error when I try to open the Lightweight Grid "Preferences" tab...

JLink`Java::excptn: A Java exception occurred: java.lang.NoClassDefFoundError: Could not initialize class ch.qos.logback.classic.PatternLayout
    at com.wolfram.remoteservices.client.impl.LogbackProxy.configureDefaultLogging(LogbackProxy.java:68)
    at com.wolfram.remoteservices.client.impl.LogbackProxy.configure(LogbackProxy.java:47)
    at com.wolfram.remoteservices.client.impl.RemoteServicesClientImpl.configureLogging(RemoteServicesClientImpl.java:1378)
    at com.wolfram.remoteservices.client.impl.RemoteServicesClientImpl.<init>(RemoteServicesClientImpl.java:74)
    at com.wolfram.remoteservices.client.impl.RemoteServicesClientImpl.<init>(RemoteServicesClientImpl.java:69)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at java.lang.Class.newInstance0(Unknown Source)
    at java.lang.Class.newInstance(Unknown Source)
    at com.wolfram.remoteservices.client.RemoteServicesClientFactory.createClient(RemoteServicesClientFactory.java:73).

Here are some pertinent details:

  • I started getting the error after installing version 10
  • I get this same error on version 9 too, which used to work fine
  • I copied the logback classic jar file on the JLink` default classpath... no effect
  • I tried reinstalling Lightweight Grid to no avail...

Is anybody having these same problems? Does anybody have an idea what's up?

$\endgroup$
  • $\begingroup$ Are you still able to launch LWG kernels using a command line? E.g., LaunchKernels[LightweightGrid[{"Agent"->[name],"KernelCount"->x}]]. Probably best to send this to tech support at WRI with your system information. $\endgroup$ – ChadK Aug 22 '14 at 14:44
  • $\begingroup$ Thanks ChadK! I get the same JLink/Java exception when I try to LaunchKernels[LightweightGrid[...]]. Will contact WRI and update this forum when they respond. $\endgroup$ – ktakagaki Aug 23 '14 at 15:29
  • $\begingroup$ So have they? :) $\endgroup$ – Kuba Dec 19 '15 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.