5
$\begingroup$

Mathematica V10 returns an error when download directory.

URLFetch :: invhttp: "FTP: could not retrieve (RETR failed) the specified file."

V9 successfully retrieves the same reference. This code successful: Import["ftp://source:get@ftp.palemoon.org/integrated_statusbar-3.0.zip"] But this failed: Import["ftp://source:get@ftp.palemoon.org/"]

$\endgroup$
  • $\begingroup$ Import[Login:Password@HOST/] $\endgroup$ – Kypaku Aug 15 '14 at 16:15
  • 2
    $\begingroup$ What is the code you are using? $\endgroup$ – bobthechemist Aug 15 '14 at 17:05
  • 1
    $\begingroup$ Importing from FTP works for me in version 10 under Windows; example: Import["ftp://source:get@ftp.palemoon.org/integrated_statusbar-3.0.zip"] $\endgroup$ – Mr.Wizard Aug 15 '14 at 18:36
  • $\begingroup$ Your link my works too. But if you try to Import[("ftp://source:get@ftp.palemoon.org/")] then returns the same error as I $\endgroup$ – Kypaku Aug 15 '14 at 18:57
  • $\begingroup$ @Kypaku Do I understand that getting a directory list is what fails in v10, but this worked in v9? If that is the case please update your question to state this and I shall reopen it. $\endgroup$ – Mr.Wizard Aug 16 '14 at 3:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.