0
$\begingroup$

I started Mathematica 10 and run as the tutorial says:

trainingset = {1 -> "A", 2 -> "A", 3.5 -> "B", 4 -> "B"};
c = Classify[trainingset]

but the outut is :

Classify[{1 -> "A", 2 -> "A", 3.5 -> "B", 4 -> "B"}]

which is not expected.

System: Windows 7, x64

$Packages gives:

{"QuantityUnit`", "HTTPClient`", "HTTPClient`OAuth`", 
 "HTTPClient`CURLInfo`", "HTTPClient`CURLLink`", "Utilities`URLTools`", "JLink`", 
 "WolframAlphaClient`", "GetFEKernelInit`", "ResourceLocator`", "PacletManager`", 
 "System`", "Global`"}
$\endgroup$
1
$\begingroup$

Problem Solved.

  1. If I start Mathematica 10 and immediately run

    Context["Classify"]
    

    it will says

    Context::notfound: Symbol Classify not found

    and if I run

    Context[Classify]
    

    note: without quote. Mathematica will tell you:

    "Global`"

  2. But When I run

    Needs["MachineLearning`"]
    

    and then run

    Context["Classify"]
    

    Mathematica gives

    System`

    It seems wired that it is not in the MachineLearning package.

$\endgroup$
  • $\begingroup$ Not weird, just not loaded, so on initial parse, it shows up as part of Global` . As to why it didn't load when you executed the example is very curious. $\endgroup$ – rcollyer Aug 11 '14 at 13:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.