I am using Linux (CentOS, Gnome 3.8.4) and I suspect this is an OS dependent problem.

When I input some text, and use mouse to select the text as follows: First press the mouse left button, keep holding the button while move the mouse to select something, and do not release the button for about 5 seconds (i.e. typical selection process, only hold the button for longer time). Then a window jumps out:

enter image description here

I have to press wait (if I press Esc, Mathematica is killed, without asking me to save anything).

I am not sure if it is a bug of Mathematica, or the Linux Gnome side. When using KDE there is no such problem.


(1) Sounds like my expression is not clear :) Here is screencast:


Note that after selecting the letter a, I didn't release the mouse button.

(2) In Mathematica 9, there is no such problem.

  • $\begingroup$ @Öskå See EDIT. No problem in v9. Screencast made. $\endgroup$
    – Yi Wang
    Commented Jul 18, 2014 at 21:39
  • $\begingroup$ @Öskå In Gnome with GnomeShell, it is builtin. Press ctrl+shift+alt+r to start and end screencast. $\endgroup$
    – Yi Wang
    Commented Jul 18, 2014 at 21:46
  • $\begingroup$ I don't have this issue, although I'm using Gnome with Ubuntu 12.04, but this looks like another issue I had: When you make a 3d plot and you start rotating the graphics and then (like you) stop and doesn't release the mouse, the whole Mathematica turns gray as it weren't responsive any more. For me, this was an issue of advanced Gnome settings which, once turned off, vanished. $\endgroup$
    – halirutan
    Commented Jul 18, 2014 at 23:00
  • $\begingroup$ I can confirm on Fedora 20 and Gnome 3.10. $\endgroup$ Commented Jul 19, 2014 at 8:01
  • $\begingroup$ @halirutan : which gnome setting is that? $\endgroup$
    – Yi Wang
    Commented Jul 19, 2014 at 8:25

1 Answer 1


I was having kind of the same problem. I didn't had an error dialog like you and for me, the issue appeared when I rotated 3d graphics. When I did this, after a second or two, the notebook window grayed out too, although when I released the mouse button, everything turned back to normal.

normal windowgrayed window

This seems to be a common problem and has to do with the settings of compiz. The solution can be found here and hopefully, it solves your problem too.

  • $\begingroup$ Thanks for the answer! Now almost only Ubuntu use compiz, and gnome shell is using another window manager named mutter. Considering neither Ubuntu unity nor KDE has this problem, it should be mutter (or anywhere else in gnome shell) who does not work well with Mma v10. Nevertheless, thank you again and the answer may be helpful for other people :) $\endgroup$
    – Yi Wang
    Commented Jul 19, 2014 at 10:53
  • $\begingroup$ On the other hand, it may be a common problem that Mathematica looks not responsive in some cases, which triggers misbehavior of window managers. $\endgroup$
    – Yi Wang
    Commented Jul 19, 2014 at 10:56
  • $\begingroup$ Maybe this gives you a starting point for your search for the problem. It seems when Mathematica's graphics is rotated or the mouse button is pressed and held, it looks like it is unresponsive and Gnome brings up a message. For me the solution was to turn off that Gnome cares about unresponsive programs. Maybe you can ask on a Gnome site how you can track this issue down. $\endgroup$
    – halirutan
    Commented Jul 19, 2014 at 11:20
  • $\begingroup$ Thanks! I notice that there are complains for other application with similar behavior under mutter. The solutions, if exist, are at the application side and this mutter behavior is hard coded in mutter source code without configuration options. $\endgroup$
    – Yi Wang
    Commented Jul 19, 2014 at 11:49
  • $\begingroup$ This also happens with Mutter (GNOME Shell). Any idea how to solve it in Mutter (the solution you give only works with Compiz-based systems, obviously). EDIT: @YiWang, so no solution then. What a pitty. $\endgroup$ Commented Jan 14, 2015 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.