On my machine (Windows 8.1) and M10 the following two lines, that must be run on an already saved notebook,

Manipulate[Plot[a x^2, {x, -4, 4}, PlotRange -> {-4, 4}], {{a, 1}, -10, 10}]
Export[NotebookFileName[] <> "~", EvaluationNotebook[], "NB"];

cause a strange error message, saying:

Click here to find out if this problem is known, and to help improve
the Wolfram System by reporting it to Wolfram Research.

(the "here" link redirect me to this page, with my license data attached to the link).

The error message is generated when the Export command is executed, but only if the first Manipulate command was previously executed (so that there is a dynamic output graphics object). If there's no dynamic output the export command works as expected. Disabling Dynamic updating in the Evaluation Menu has no effect.

In M9 the Export command works fine (no error messages) also with the presence of some dynamic output.

The message is rather annoying, but, anyway, the export command succeeds.

I need a fix for this because the Export command is used in the "Mathematica Notebook Auto Backup Package" by Josh Burkart (available here: https://github.com/joshburkart/mathematica-autobackup). This package is very useful to create backups of the current notebook at user-defined intervals and with other configurable options. Furthermore I really don't like the alternative route of enabling the NotebookAutoSave option since with that procedure you lose the safe and last "deliberately saved" version of the notebook.

It is even more necessary now that, before the next maintenance release, M10 may run into some crashes (not infrequent, at least in some system, and that's the main reason why I searched and found that package).

Can somebody check if the two code lines above give the error also with other machines? (Note that the notebook must be saved before running the Export command).

Any possible advice to avoid that annoying error message?

  • 1
    $\begingroup$ I ran the code in a saved Notebook as instructed without apparent error. I am using v10.0.0 under Windows 7. All I can offer is the remote possibility that this is related: (54957) $\endgroup$ – Mr.Wizard Jul 16 '14 at 12:49
  • $\begingroup$ Thanks. Anyway I don't think that the related question is relevant for mine. In my case the Export command works but for the presence of some dynamic output in the notebook, and, apart form the error message, the command succeeds. $\endgroup$ – Luca M Jul 16 '14 at 12:54
  • 1
    $\begingroup$ I get the same error on ($Version ==) 10.0 for Mac OS X x86 (64-bit). Thanks, I was having the same problem, I hope we can sort this out. $\endgroup$ – Jacob Akkerboom Jul 16 '14 at 14:42
  • $\begingroup$ ExportString[obj, "CDF"] from my post [mathematica.stackexchange.com/questions/55566/… also generate the same error message on "10.0 for Microsoft Windows (64-bit) (June 29, 2014)" $\endgroup$ – akm Jul 23 '14 at 8:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.