I have messed up the font size globally. I was playing with SetOptions and I think I have accidentally changed the font setting of the FronEnd setting globally as can be seen here.

enter image description here

I tried to uninstall Mathematical and instal it again but that did not help. how can I reset the font size to default.

  • $\begingroup$ You may want to try this: support.wolfram.com/kb/3274. I haven't tried it since I obviously don't want to lose my MMA settings. If it works, credits to @halirutan for pointing me to it in the chat. $\endgroup$ – seismatica Jul 16 '14 at 7:28

Most likely you merely set to some $FrontEnd options unintentionally. If you can figure out what these options are you can reset them by clicking the X next to the field in the Option Inspector:

enter image description here

You can also select as text rather than by category to see a list of all the options that have been changed from the default (manually or otherwise).

  • $\begingroup$ I was trying to understand your answer here: mathematica.stackexchange.com/questions/14536/… and here : mathematica.stackexchange.com/questions/10776/… but then every thing messed up. $\endgroup$ – Algohi Jul 16 '14 at 8:13
  • $\begingroup$ @Algohi Sorry. :-( Do I understand correctly that you were editing Style Sheets? $\endgroup$ – Mr.Wizard Jul 16 '14 at 8:20
  • $\begingroup$ I was trying to change the font globally because I had complicated graphic so that I do not need to manually style the fonts of everything in the graph. but then I released that I did some thing wrong which messed up the font globally. $\endgroup$ – Algohi Jul 16 '14 at 8:30
  • $\begingroup$ @Algohi Do you recall what exactly you were doing? Of course you don't know what went wrong, but it would help to know in what manner it happened. Were you editing style sheets? Using SetOptions? Something else? $\endgroup$ – Mr.Wizard Jul 16 '14 at 9:14
  • 1
    $\begingroup$ @Algohi I'm glad you were able to resolve that problem. Incidentally (I believe) that setting could have been reset as described in my answer above. The Option Inspector can be opened from the command in the Format menu of the menu bar, or Ctrl+Shift+O in Windows. Be sure to select Global Preferences and by category. Then type FontSize into the Lookup: field and it should take you right to that setting. Or you can navigate to it using the tree view in the left pane. $\endgroup$ – Mr.Wizard Jul 18 '14 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.