Bug introduced in 10.0.0 and fixed in 10.0.2

In version 10.0, when I leave the Mathematica section idle for some time (of order an hour), the kernel quit automatically. The syntax highlighting is gone and the variables that has defined before lost their values. There is no error message (tried to launch from terminal and still no error message).

This behavior has been noticed on my computer for many times. No operation is performed. Simply launch Mathematica 10 and wait (or define a variable and watch it gone). Mathematica 9 is installed side by side and has no such problem. I am using Linux (CentOS 7).

Anyone has the same problem, or any suggestions to further debug?


10.0 for Linux x86 (64-bit) (June 29, 2014)

uname -a

Linux localhost.localdomain 3.10.0-123.el7.x86_64 #1 SMP Mon Jun 30 12:09:22 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux


I unchecked Preference -> Internet Conectivity -> Allow the Wolfram System to access the Internet. The kernel hasn't crashed since this change is made.

  • 2
    $\begingroup$ I got something similar, although I haven't noticed that I particularly left Mathematica alone. I just noticed that my kernel has crashed after a while. I'm trying now to leave it idle. My OS is Ubuntu 12.04. $\endgroup$
    – halirutan
    Commented Jul 13, 2014 at 23:55
  • 1
    $\begingroup$ This is at least the third different crash report of version 10 here in the last 8 hours alone. I think I'll postpone my upgrade until 10.1 :-( $\endgroup$
    – stevenvh
    Commented Jul 14, 2014 at 10:16
  • 1
    $\begingroup$ Is this observed on any other OS? $\endgroup$
    – rcollyer
    Commented Jul 14, 2014 at 12:33
  • 1
    $\begingroup$ My Mathematica 10 has been on for over 3 days now. I don't have this problem on Windows 8.1 $\endgroup$
    – RunnyKine
    Commented Jul 14, 2014 at 13:12
  • 2
    $\begingroup$ I've been having this same problem (but only after a few minutes idle time) with Mathematica 10.0 on Mac OS X 10.9.4. I had contacted Wolfram Support but it's being investigated. I will try the workaround! $\endgroup$ Commented Aug 13, 2014 at 23:07

2 Answers 2


To upgrade my comment to an answer, and perhaps give some more background information:

This bug has been fixed as of version 10.0.2. The crash happened in the libcurl library, which is being used in a separate thread via the HTTPClient package by the paclet manager at kernel startup to check for updates. It had to do with thread safety in certain circumstances, namely a DNS resolver thread taking too long to complete its task. It is essentially the same problem described here or here.

  • $\begingroup$ Can you check if this is a bug, or a misunderstanding of how the functions should be used, please? $\endgroup$
    – Szabolcs
    Commented Aug 31, 2015 at 22:20
  • $\begingroup$ @Szabolcs It does feel like a bug, though this is not my area. I forwarded your post to the people who have implemented that functionality. $\endgroup$
    – ilian
    Commented Sep 1, 2015 at 18:17

Now that the workaround has worked for me for days without crash, let me put it as an answer myself. The crash (at least in my case) is because of the kernel tries to connect to internet and something wrong happened there. To solve the problem, uncheck

Preference -> Internet Conectivity -> Allow the Wolfram System to access the Internet

  • 5
    $\begingroup$ amazing bug. Kernel crashes because it can't connect to the internet ! $\endgroup$
    – Nasser
    Commented Jul 16, 2014 at 6:43
  • 1
    $\begingroup$ I saw a similar issue when I tried some geodata stuff on a ferry with extremely congested satellite link and a transparent HTTP proxy. I wasn't able to reproduce the issue, but it certainly seemed like an issue with network connectivity. $\endgroup$
    – kirma
    Commented Jul 18, 2014 at 6:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.