As often happens with Mathematica updates, nearly all of my notebooks no longer work as they did with the previous version. The upgrade from 9 to 10 has changed the appearance or introduced errors into almost every figure or graphic I create. I'm also encountering many errors in code that has worked without error since version 7. Many of these errors are quite surprising (e.g. calculations that suddenly give division by zero errors on the same data that I've always used, out of range errors when indexing lists that have not changed since running in version 9, graphics suddenly scaling to different sizes than before, etc.), and very difficult to locate (they are generally in large notebooks that I've been using for years).

Is there a tool for analyzing version 9 code for potential issues in version 10?

I've enabled the notebook compatibility scanning feature; but that does not detect anything in any of my affected notebooks:

As I spend hours going through my code to track down the sources of my many 10-induced bugs, I've come across the following, so far:

  • DateDifference now returns a Quantity so that comparisons need to be wrapped in QuantityMagnitude (documented).
    This leads to all kinds of errors, as many tests, filters and comparisons now fail (x≠x days for example), resulting in lots of empty lists.
  • DateListPlot seems to behave as if Joined is True by default (apparently not documented).
  • Default line weights and point sizes have changed in many (all?) plots, with now clear way to restore them to exactly what they were before.
    This is vexing if you've got any kind of document production or style guidelines you've been following: all your code will now need to be adjusted to produce the results you've had.
  • I DateListPlot, if two points have the same time coordinate, only one is plotted; the others are ignored.

In addition, I'm getting at least a strong subjective impression that many operations are much slower, especially file imports (e.g. importing several GPX files taking hours — so far — rather than minutes, in 9). There also appears to be some pollution of the global namespace taking place: I can get errors and very long delays in execution depending on the order in which I run different notebooks. I've had no luck tracking down the source of this behavior; but it's quite consistent.

  • $\begingroup$ Some problems might be fixed by reverting aspects of the system to earlier behavior; e.g. loading Verion5 Graphics in versions 6 or later, to make old Notebooks work better. Is this kind of work-around acceptable, or do you want to preserve all the new features/changes and update your code? $\endgroup$
    – Mr.Wizard
    Commented Jul 11, 2014 at 18:04
  • $\begingroup$ @Mr.Wizard: I'd like to be able to use my notebooks in version 10, as I'd expect to be able to do. If there are occasional things that need tweaking, I just need to locate them and change them. In the past, I've just had to abandon projects to get things working. $\endgroup$
    – orome
    Commented Jul 11, 2014 at 18:11
  • $\begingroup$ Any specific examples for community members to play around with? (Not that my license has been updated, grumble) $\endgroup$ Commented Jul 11, 2014 at 18:26
  • 4
    $\begingroup$ @bobthechemist: I'm trying to whittle things down into a form that's useful as a M(N)WE; but that's the issue, most of these errors are occurring deep in big notebooks (or sets of several notebooks), so its hard to isolate the issues. I'd have thought that if 10 was going to introduce issues where there had been none before, it would have come with some tools to isolate them (hence my question). $\endgroup$
    – orome
    Commented Jul 11, 2014 at 19:04
  • $\begingroup$ For plots, did you try including option PlotTheme -> None? $\endgroup$
    – murray
    Commented Aug 8, 2014 at 15:20

1 Answer 1


Found also a horrible error in DateListPlot in Mathematica 10: If two points have the same time coordinate, only one is plotted; the others are ignored. This was different in Mathematica 9, where all points would be plotted correctly. I very much hope that this glaring error gets corrected soon.

  • 2
    $\begingroup$ This is an interesting and useful observation, but it isn't an answer to this specific question. I think it is worth a separate question that exposes the bug. $\endgroup$
    – rm -rf
    Commented Aug 8, 2014 at 13:19
  • $\begingroup$ Good catch. Added to list in original question. @rm-rf is right though; this belongs in a new question (let me know the URL and I'll link from mine). $\endgroup$
    – orome
    Commented Aug 10, 2014 at 21:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.