57
$\begingroup$

In version 10, when the mouse is over a Mathematica command, a small pop-up window comes up that one can click on for help on the command.

Is there an option to disable this feature? Screen shot:

Mathematica graphics

I tried number of options here, but no effect. It must be in the advanced perferences? But not sure what to look for.

Update:

Thanks to Martin answer below. These options can be changed permanently in advanced options

Mathematica graphics

I also turned off the "ShowCodeAssist" just in case

Mathematica graphics

$\endgroup$
  • 1
    $\begingroup$ I want to remove the mousover floater (=popup window) without switching off the autocomplete assistant (Mathematica 11.0 Windows 7). I have tried all the solutions below (AutoPopupEnable->False, ShowCodeAssist->False, CodeAssistOptions->{"FloatingElementEnable"->False} but none of them works. The first 2 solutions disable both functions, the third do nothing. $\endgroup$ – andre314 Nov 13 '16 at 18:18
35
$\begingroup$

Unfortunately I cannot claim the original discovery, but there are additional CodeAssistOptions in M10, the one you want is:

SetOptions[EvaluationNotebook[], CodeAssistOptions -> {"FloatingElementEnable" -> False}]

You could replace EvaluationNotebook[] with $FrontEnd but I prefer not to change $FrontEnd options.

$\endgroup$
  • 8
    $\begingroup$ You could use $FrontEndSession to make it temporary $\endgroup$ – Mike Honeychurch Jul 10 '14 at 0:35
  • $\begingroup$ @MikeHoneychurch I'm an unusual user, I need it to show in most all my notebooks but in a small number I never ever want it to show. You're right, for most people $FrontEndSession would be the way to go. $\endgroup$ – Martin John Hadley Jul 10 '14 at 10:15
  • $\begingroup$ This doesn't appear to work as of Mathematica 11.3, looks like same problem as with another GUI-based answer. $\endgroup$ – Ruslan Jan 30 at 15:12
13
$\begingroup$

For what it's worth, the accepted answer does not function in the Raspberry Pi version of Mathematica. A slight change gets you the result:

SetOptions[EvaluationNotebook[],"ShowCodeAssist"->False]

This is particularly helpful on the RPi since the code assist links attempt to find the nonexistent documentation. [The RPi does not ship with documentation and users must go to the web for references.)

$\endgroup$
  • $\begingroup$ This also removes the code-completion assistant, which is otherwise helpful during typing. Is there any way to have the completion floater but not the mousover floater? It seems like I either have both or none (or only the mouseover floater but not the former). (Mathematica 10.1 Win7) $\endgroup$ – István Zachar Apr 21 '15 at 14:10
  • $\begingroup$ @IstvánZachar I don't know the answer to your question. I've only explored the issue on the RPi, and for my purposes, having neither autocompletion nor mouseover was the best scenario. $\endgroup$ – bobthechemist Apr 21 '15 at 17:23
  • $\begingroup$ @IstvánZachar you can trigger code completion popup by pressing <F2>, at least on Linux/Windows versions. $\endgroup$ – Ruslan May 4 '15 at 6:50
  • $\begingroup$ To make this permanent, replace EvaluationNotebook[] with $FrontEnd, similarly to the accepted (but not working) answer. $\endgroup$ – Ruslan Jan 30 at 15:13
8
$\begingroup$

One can also use the menu bar. Go to Edit ▶ Preferences... and under the Interface tab one can uncheck "Enable floating elements ..." enter image description here

Alternatively, one can increase the delay to a number that is big enough to prevent an unwanted pop up.

$\endgroup$
  • $\begingroup$ I can't find this option on Mathematica v10 on Linux $\endgroup$ – JeffDror Jun 9 '15 at 16:53
  • $\begingroup$ @JeffDror it is there between autocompletion and natural language detection options on my MMA 10.1 on Linux. $\endgroup$ – Ruslan Feb 14 '16 at 7:21
  • $\begingroup$ @andre For me (using version 11.0.1 under Windows 10) unchecking the box, as shown in my answer, disables the appearance of the floating element during mouse overs. However, the same element appears as part of the autocompletion, but placed at a different position. Does disabling the appearance of the element during mouse overs work for you? $\endgroup$ – Karsten 7. Nov 13 '16 at 19:44
  • 4
    $\begingroup$ This doesn't work as of Version 11.1. Instead, go Edit -> Preferences -> Advanced -> Open Option Inspector -> Editing Options -> Private Editing Options -> Code Assist Options -> Floating ElementEnable $\endgroup$ – axsvl77 Sep 22 '17 at 14:21
  • $\begingroup$ @axsvl77 doesn't take effect in 11.3 for some reason. Increasing delay also doesn't take any effect... $\endgroup$ – Ruslan Sep 28 '18 at 14:26
0
$\begingroup$

The popup window you are talking about is removed by the ShowCodeAssist option set to false. The other settings don't concern your problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.