5
$\begingroup$

Is there a way to personalize the startup? I want, for example, that mathematica starts Maximized (not slightly-less-than-maximized as it usually does) with a notebook (also maximized) with a zoom of 130%. I use mathematica 8.0.4 and windows XP.

$\endgroup$
3
  • $\begingroup$ Do you mean you want the new notebook to open in full-screen, or just as a maximized window? I think I know how to launch in real full screen mode on Mac OS X, but it involves Applescript, so it's platform dependent. What is your platform? $\endgroup$
    – Jens
    May 5 '12 at 18:41
  • $\begingroup$ @Jens No need for applescript... SetOptions[SelectedNotebook[],WindowSize -> Full] does it :) $\endgroup$
    – rm -rf
    May 5 '12 at 18:47
  • $\begingroup$ @R.M. Thanks - that's better. I just thought of scripting because I have one notebook that I always launch via Applescript, so I would have re-used that approach... $\endgroup$
    – Jens
    May 5 '12 at 18:52
4
$\begingroup$

I find it easiest to create a Notebook with the features I want, and then open that Notebook to launch Mathematica.

Save this code as a .nb file. If you want Mathematica to also open "Maximized" rather than in the slightly-less-than-Maximized form it usually does, also create a shortcut to this Notebook and change the properties to Maximized, then use that.

Notebook[{},
  Saveable->False,
  WindowSize->Scaled[1],
  WindowMargins->{{Automatic, 0}, {Automatic, 0}},
  Magnification->1.3,
]
$\endgroup$
8
  • $\begingroup$ If you tried the version with Editable->False and of course it failed, please try now. $\endgroup$
    – Mr.Wizard
    May 5 '12 at 18:40
  • $\begingroup$ why Saveable -> False? Or is this your invisble notebook/ $\endgroup$
    – rm -rf
    May 5 '12 at 18:48
  • $\begingroup$ @R.M Saveable -> False so that you do not accidentally overwrite this starting Notebook and have to create it again. Mathematica should still prompt you to save the file on closing. $\endgroup$
    – Mr.Wizard
    May 5 '12 at 18:49
  • $\begingroup$ @Mr.Wizard Mathematica doesn't prompt me to do save the file on closing but when i open this notebook, it is in fullscreen mode and with the right magnification,as desired and what do you exactly mean with "change the properties to maximized". $\endgroup$
    – Zero
    May 5 '12 at 19:38
  • 2
    $\begingroup$ @Mr. Wizard in fact, the documentation says: A notebook with the option setting Saveable->False can always be saved using the Save As menu item, but does not respond to Save and does not prompt for saving when it is closed. $\endgroup$
    – Zero
    May 5 '12 at 20:20
4
$\begingroup$

In MMA prefs / advanced/ open option inspector and you can set the values you want to customize. Full screen is under Window Size and select "Full". Zoom is under Notebook Options/ Display options/ Magnification.

$\endgroup$
2
  • 1
    $\begingroup$ Selecting "Full" under Notebook Options/Windows properties/Windows size does nothing but the magnification worked well. $\endgroup$
    – Zero
    May 5 '12 at 19:10
  • $\begingroup$ F12 or cmd/option/F will also give you full screen. $\endgroup$
    – R Hall
    May 5 '12 at 21:36
0
$\begingroup$

You could either edit the Default.nb notebook to fit your needs, or inherit from it to create another stylesheet, and set it as the default by changing $FrontEnd's DefaultStyleDefinition's option to that new notebook.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.