1
$\begingroup$

I was playing around with the printing options because at first my notebook's printout was strangely way too large. However, after apparently solving the problem, now I noticed that when I print out this test graph (adapted from here), the labels and axis titles got smushed in when printing even though they show up fine in both the Working and Printout environment. I tried to remove the formatting of the graph (ImageSize->400, LabelStyle->14, RotateLabel->False) so that MMA would print the graph the best way it sees fit, but that didn't solve the probe

Any idea what might have caused this behavior?

energy[theta_, speed_, m_, g_, len_] := 
  m g len (1 - Cos[theta]) + (1/2) m len^2 speed^2;

m = 1; g = 9.8; len = 10;

data = Table[
   energy[i, j, m, g, len], {j, -4, 4, .01}, {i, -3 Pi, 3 Pi, Pi/20.}];

ListContourPlot[data, InterpolationOrder -> 2, Contours -> 20, 
 MaxPlotPoints -> 30, DataRange -> {{-3 Pi, 3 Pi}, {-4, 4}}, 
 FrameTicks -> {{{-4, -3, -2, -0, 1, 2, 3, 4}, 
    None}, {{-3 Pi, -2 Pi, -Pi, 0, Pi, 2 Pi, 3 Pi}, None}}, 
 FrameLabel -> {{"\[Theta]'(t)", None}, {"\[Theta](t)", 
    "constant energy levels for nonlinear pendulum model"}}]

Smushed in label

$\endgroup$
  • 1
    $\begingroup$ Works fine for me (Mathematica 9.0.1.0 on Mac). Have you tried restarting the kernel? $\endgroup$ – Rahul Jun 1 '14 at 22:28
  • 1
    $\begingroup$ it works fine also for me on windows 7, V 9.01 mathematica. Looking at the fonts you are using, since you seem to have changed coloring using by notebook front end from default, may be this has something to do with it? If so, this could be a bug in FE as it should not do this. $\endgroup$ – Nasser Jun 2 '14 at 0:36
1
$\begingroup$

I think I found the culprit: I tried to set my screen resolution (outlined here) up to 108 to enlarge the Working environment while hoping at the same time it won't make the printout too large.

SetOptions[$FrontEndSession, 
 FontProperties -> {"ScreenResolution" -> 108}
] 

To reverse that change, I changed the resolution to Inherited (you can also try Automatic to see what happens--I don't want to mess with my notebook more than I already have)

SetOptions[$FrontEndSession, 
 FontProperties -> {"ScreenResolution" -> Inherited}
]

Now back to my original goal: to enlarge my Working environment, I just follow the Options Inspector route (outlined in the same link by @Szabolcs). Strangely the printout does not seem to be affected this time i.e. it prints out at normal size, whereas in earlier attempts I noticed the printout was really big after changing the global magnification. Not sure why that is but you can try changing the global magnification in the Options Inspector and see if everything is printed out properly.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.