9
$\begingroup$

Lately, my installation of Mathematica has decided not to highlight any symbols loaded from packages. The picture below is a good representation of this:

enter image description here

where after loading both PhysicalConstants` and Units` BohrRadius, Meter, and Angstrom should all be black. Yet, they retain their "unknown symbol" color. This occurs for all packages and is persistent across restarting the front-end and rebooting the entire system. Any suggestions for correcting this?

I am running the student version of 8.0.4 on MacOS 10.6.8.

$\endgroup$
6
  • $\begingroup$ What happens when you deselect highlighting of "Global symbols that have no value assigned" in the Preferences dialog? Does my suggestion below function then? $\endgroup$
    – Mr.Wizard
    Apr 29, 2012 at 14:49
  • $\begingroup$ @Mr.Wizard no it doesn't. $\endgroup$
    – rcollyer
    Apr 29, 2012 at 15:12
  • $\begingroup$ I just want to add this happens constantly to me, especially if I have aborted a calculation using Command + period. The only remedy is to restart Mathematica entirely (restarting the kernel alone does not work). I'm pretty sure this is just a bug in Mathematica. $\endgroup$
    – Guillochon
    Apr 29, 2012 at 21:10
  • $\begingroup$ @Guillochon yes, I have that happen, also. But, this was persisting beyond restarting mathematica. $\endgroup$
    – rcollyer
    Apr 30, 2012 at 0:58
  • $\begingroup$ Was this ever resolved? $\endgroup$
    – Mr.Wizard
    Oct 14, 2012 at 10:38

1 Answer 1

11
$\begingroup$

I don't know what is causing your problem, but presumably you can still specially color the symbols in those contexts as I do. For example:

SetOptions[$FrontEnd, 
  AutoStyleOptions -> {"SymbolContextStyles" ->
     {"Units`" -> Brown, "PhysicalConstants`" -> Orange}
   }
]

Since the above suggestion doesn't have effect on your machine even when you deselect highlighting of "Global symbols that have no value assigned" in the Preferences dialog, it sounds like something is really broken. Obviously backing things up first, try deleting the user configuration files.

$\endgroup$
11
  • $\begingroup$ No dice. I think the highlighter is viewing them as not having any values assigned to them, so it is not moving off of the blue. $\endgroup$
    – rcollyer
    Apr 29, 2012 at 14:37
  • $\begingroup$ @rcollyer I'm doing it directly in the Options Inspector (or perhaps I should say the settings reside in the FrontEnd/init.m file), but really it's just a matter of preference, isn't it? $\endgroup$
    – Mr.Wizard
    Apr 29, 2012 at 14:39
  • $\begingroup$ Which files in particular? The $UserBaseDirectory/FrontEnd/8.0 Caches? $\endgroup$
    – rcollyer
    Apr 29, 2012 at 15:13
  • 1
    $\begingroup$ I moved both $UserBaseDirectory/FrontEnd/8.0 Caches and init.m from $UserBaseDirectory/FrontEnd, restarted, and it appears to have worked. I'm wondering what got fubared ... Any way, edit you comment in to your answer, and I'll accept it. $\endgroup$
    – rcollyer
    Apr 29, 2012 at 15:18
  • $\begingroup$ No real customizations to speak of. $\endgroup$
    – rcollyer
    Apr 29, 2012 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.