9
$\begingroup$

Bug introduced in 9.0 or earlier and fixed in 10.0


In the documentation of Mathematica it is mentioned that you can use Hyperlink and Tooltip as wrapper in a similar manner as Style. However, the following example does not seem to work: vertices 1 and 2 are highlighted in Red but there is neither hyperlink access nor tip.

HighlightGraph[Graph[{1 -> 2, 2 -> 3}], {Tooltip[1, "TEST IT!"], 
                 Hyperlink[2, "http://stackexchange.com/"]}]

Did I miss something ?

$\endgroup$
  • 1
    $\begingroup$ I have to evaluate the Output to make it work: see here. Windows7 V9.01. $\endgroup$ – Öskå Apr 17 '14 at 15:03
  • $\begingroup$ Thank you. However in your demo, you have validated the output of the code line to enable the hyperlink, and effectively it works. I don't understand why two validations are required ? $\endgroup$ – Gurwho Apr 17 '14 at 18:06
  • $\begingroup$ More comments should come with more feedback :) $\endgroup$ – Öskå Apr 17 '14 at 18:53
  • 2
    $\begingroup$ Same issue with Graph[{Property[1, Tooltip -> "Test"], Property[2, Hyperlink -> "http://stackexchange.com/"]}, {1 \[DirectedEdge] 2, 2 \[DirectedEdge] 3}] using V9.0.1 on Windows 7. $\endgroup$ – kglr Apr 17 '14 at 19:12
  • 3
    $\begingroup$ I'm prepared to call this a bug. BTW It is an interesting exercise to open up the original graph output and Öskå's version (the evaluated graph) using ctrl-shift-E and look for the differences. $\endgroup$ – Sjoerd C. de Vries Apr 17 '14 at 19:58
6
$\begingroup$

This works correctly in version 10.0 and later.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.