How do I change the default precision in Mathematica?

Somehow the setting has been changed to 1 digit, so if I type


I get

{1., ...}

which is not very enlightening. Similarly,




Compare Mathematica's documentation for Numerical Precision which says of the above command "In standard output form, Mathematica prints a number like this to six digits." So something isn't right with my setup.

I read the guide to numerical precision but it didn't appear to address this issue.

Note that I do not want to change WorkingPrecision or PrecisionGoal on a particular function,but just change the default setting. (Of course I'll have to adjust these in some cases, but I just want to have a sensible starting point.)

  • $\begingroup$ I have marked this as "already has an answer here:" because I think it has. If PrintPrecision does not solve your problem @comment me or flag this post for moderator attention. $\endgroup$
    – Mr.Wizard
    Mar 13, 2014 at 15:13
  • $\begingroup$ @Mr.Wizard: Thanks. Actually this doesn't address my problem. For example, the documentation says of N[Pi] "In standard output form, Mathematica prints a number like this to six digits." But I get 0, and I don't want to have to append PrintPrecision to every command I run. (I'm not even sure if it applies to a command like Timing in any case.) $\endgroup$
    – Charles
    Mar 13, 2014 at 16:53
  • 1
    $\begingroup$ Did you change any options under Preferences->Appearance->Numbers->Formatting? Are you working on a fresh kernel? Your question title may be misleading if your display is somehow messed up. $\endgroup$
    – Yves Klett
    Mar 13, 2014 at 18:26
  • $\begingroup$ @YvesKlett: That's it! Thank you. $\endgroup$
    – Charles
    Mar 13, 2014 at 18:28
  • $\begingroup$ @Mr.Wizard the correct answer is in the linked thread, but the accepted one does not adress the issue here... best practice? $\endgroup$
    – Yves Klett
    Mar 13, 2014 at 18:33


Browse other questions tagged or ask your own question.