I am trying to install Mathematica 9 on a Ubuntu 13.10 system. I had this working on my previous 13.04 version but now it breaks on when trying to unpack the sh archive:

$ sh Mathematica_9.0.0_LINUX.sh
Mathematica Secured 9.0.0 for LINUX Installer Archive

Verifying archive integrity. 
Extracting installer. ...........................................................................
CRITICAL FAILURE: Fundamental Error
 Installer text not found.

sudo sh ... produces same error, the md5 hash checks out ok.

Anybody encountered this problem, and more to the point, figured out what is wrong? I submitted a ticket to Wolfram support but no luck there so far.

Thanks for any ideas to try.

  • $\begingroup$ Make sure there is no space in your directory name. $\endgroup$ – alephalpha Feb 19 '14 at 5:19
  • $\begingroup$ Yes I tried making it executable (should't make a difference and it didn't). Yes 'sh' is the right shell for interpreting the archive. Sticking point now is that my activation code doesn't work since the fingerprint of the machine is different after OS upgrade... $\endgroup$ – SEngstrom Feb 19 '14 at 5:20
  • $\begingroup$ @alephalpha as you can see there are no spaces in the directory I was working from. $\endgroup$ – SEngstrom Feb 19 '14 at 5:21
  • $\begingroup$ try renaming the .sh file to mma9.sh (something without dot and dash) and then run it. $\endgroup$ – Hubble07 Feb 19 '14 at 9:38
  • 1
    $\begingroup$ Ubuntu 15.10, Mathematica 10.0.2, still the same problem. SEngstrom's trick (--keep) worked like a charm. A big thank you - saved a lot of grief. Other tricks, like mv'ing the file to another dir, renaming the file, did NOT work for me. Problem's been around for a while.The installation script problem seems too difficult for the geniuses at Wolfram to fix... $\endgroup$ – ken a Jan 4 '17 at 8:00

I have just upgraded to ubuntu 14.03 and Mathematica 10. I tried to execute

sudo Mathematica_10.0.0_LINUX.sh 

and it would not install, i.e., like it could not find the Mathematica file! I also tried renaming, making it executable, being super user. Nothing worked.

I did a head of the MM sh and noticed it has the first line is


I looked at /bin/sh on my system and it is a link /bin/sh -> dash

Anyway I tried using bash instead dash as superuser:

bash Mathematica_10.0.0_LINUX.sh

and the install worked perfectly.

sudo bash Mathematica_10.0.0_LINUX.sh 

would probably have worked as well, but didn't try it.

I got the idea to try this from SEngstrom's post, but note with this I did not have to use the --keep or cd to the installer directory.

| improve this answer | |
  • $\begingroup$ With Mathematica 10 on Ubuntu 14 I was getting an error "Can't open Mathematica_10.0.0_LINUX.sh" despite the fact the file was made executable. Command sudo bash Mathematica_10.0.0_LINUX.sh worked for me. $\endgroup$ – Weather Report Jun 13 '15 at 14:08

I worked around this by directing the shell archive extraction to keep the files:

sh Mathematica_9.0.0_LINUX.sh --keep

Then I cd'd into the Installation directory and ran the installer from there. Note that the temporary directory will named after the process number you ran the extraction in so will differ from what I had:

cd .4725/Unix/Installer
sudo MathInstaller

... success. Now to convince Wolfram to give me a new activation code for the upgraded machine.

| improve this answer | |
  • 1
    $\begingroup$ Now upgrading to Mathematica 10.0.0 - Archive extraction still breaks, this time under Ubuntu 14.04 LTS. Fix above still seems to work. $\endgroup$ – SEngstrom Jul 11 '14 at 16:19

I installed Mathematica 10 by copying the .sh insatalled to the Desktop and renaming it to "Mathematica.sh" then typing this command in the terminal:

$ cd Desktop/
$ sudo sh Mathematica.sh 

it installed correctly.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.