I am preparing a presentation on Mathematica and realized that though I made the GroupOpeners visible in the working regime (through the OptionInspector), they are invisible in the regime of the slide show.

My question: how to make the GroupOpeners visible both in the Working and SlideShow regimes? Mma 9.0.1 WinXP and Win7.

Later edit: 1) There is a possibility to use the OpenerView. But this makes all constructs a bit too heavy.
2) I apologize for a wrong term I used. It is not presentation, but a slide show regime where I need to have the openers. Now I corrected it.

  • $\begingroup$ There is also a useful tweak to make whole cells work as group openers (rather than the fiddly opener icons), but I cannot remember how that is done. $\endgroup$
    – Yves Klett
    Dec 3, 2013 at 16:56
  • $\begingroup$ I see them in presentation enviroment but no in slide show. $\endgroup$
    – Kuba
    Dec 3, 2013 at 17:18
  • $\begingroup$ @Kuba may be I used incorrect wording. I mean exactly what you write. I cannot see the openers when I am in the slide show modus, just when I need them. $\endgroup$ Dec 4, 2013 at 8:34
  • $\begingroup$ "WholeCellGroupOpener" ->True makes a cell "clickable" It's a pain while still editing, but I'll select those "heading" cells right before distribution and set that option to True. Pretty handy for students when reading the file $\endgroup$ Dec 4, 2013 at 14:54
  • $\begingroup$ @Tom De Vries Thank you. I tried. It has, however, a prohibiting side effect, which, I think, might be of a general interest. The passive cells, indeed, open quite nicely. However, as soon as I open a cell with an interactive example, I could not reach a slider. Each time I placed the cursor on the slider and pressed the left mouse button, - the cell collapsed. For this reason it is not unfortunately an option. $\endgroup$ Dec 5, 2013 at 8:17

2 Answers 2


By long toing and froing I came butt against the answer. Here you are:

  1. Open the notebook prepared for the slide show. Assume its name is mySlideShow.nb. In the Slide Show palette press the "Start Presentation" button. The notebook will come into the Slide Show mode.

  2. Go to Menu/Format/Option Inspector.

    2a. From the drop down menu of the "Selection" field choose this notebook (in this case it should be mySlideShow.nb). It is important that it is already in the Slide Show mode when you do this.

    2b. In the "Lookup" field type "ShowGroupOpener"

    2c. In the right-bottom field the line "ShowGroupOpener False" will be highlighted, the box at the field right edge is unchecked.

    2d. Check the box. This should have the effect of replacing "False" by "True".

    2e. Press "Apply". Done

 StyleDefinitions -> 
  Notebook[{Cell[StyleData[StyleDefinitions -> "XXXXXX.nb"]],
    Cell[StyleData[All, "Working"], ShowGroupOpener -> True],Cell[
      StyleData[All, "Presentation"], ShowGroupOpener -> True]}, 
   StyleDefinitions -> "PrivateStylesheetFormatting.nb"]

where "XXXXX.nb" is the name of whatever stylesheet you are using.


If this didn't work for me and I realised that I wanted it to work in SlideShow mode instead then I would write "SlideShow". At some point in this Q&A site a user has to have a modicum of initiative.

  • $\begingroup$ It does something different from what I expect. It is, probably, my fault, since I used a wrong wording. Please have a look to my edit above. $\endgroup$ Dec 4, 2013 at 8:47
  • $\begingroup$ @AlexeiBoulbitch so you want it to work in slideshow? then write "SlideShow". You have enough rep pints here to join the dots. Please tell me you didn't leave "XXXXX.nb" in the code. $\endgroup$ Dec 4, 2013 at 21:31
  • $\begingroup$ Here you are, I did not. And thank you very much. $\endgroup$ Dec 5, 2013 at 8:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.