I'm using Ubuntu 13.10 and every time I try to start Mathematica, my Ubuntu session just crashes and I get thrown to the login screen. This also happens if I try to run Mathematica from another computer through SSH and on both Mathematica 8.0 and 9.0. This behaviour started after the last time I did the normal software update for my system.

How can I try to solve this problem? I find nothing in the ~/.xsession-errors errorlog for X.

  • $\begingroup$ Can you launch mathematica from inside a terminal and redirect the (possible) output to a file, and then paste the content of that file in the question? That would provide some information. As it stands, it's almost impossible to answer, unless someone has had the same behaviour. I would suspect some X server craziness. $\endgroup$ – mgm Nov 27 '13 at 10:27
  • $\begingroup$ I tried running mathematica >> mathlog.log, but nothing was written in the file. $\endgroup$ – Echows Nov 27 '13 at 10:37
  • 1
    $\begingroup$ Hi, can you try: mathematica 2>&1 > mathlog.log ? Thanks! $\endgroup$ – mgm Nov 27 '13 at 10:46
  • $\begingroup$ Still nothing. Thanks anyway! Btw. what does that "2>&1>" actually do? $\endgroup$ – Echows Nov 27 '13 at 10:49
  • $\begingroup$ you're welcome. 2>&1 supposedly takes stderr, redirects it to stdout and the redirects both, with > mathlog.log, to the file. Can you get a list of the packages updated last? You can go look into /var/cache/apt and there are the actual deb files there, with dates. You can use the 'find' command to get only those created after a certain date (those in the last update). Thanks! $\endgroup$ – mgm Nov 27 '13 at 11:09

In my case, the problem was in the current Nvidia drivers. After a month of exchanging emails with Wolfram support, we found two possible ways to fix this:

Updating Nvidia drivers to Version 3.19

  1. Install the package nvidia-319-updates (e.g. from synaptic)
  2. Restart

Alternative: switching to Nouveau drivers

  1. Remove all packages related to nvidia (in my case, nvidia-current, nvidia-settings-304 and nvidia-304), e.g. in Synaptic.
  2. Nouveau drivers will be installed/selected automatically.
  3. Restart.
  • $\begingroup$ After some difficulties, I managed to switch to Nouveau drivers (it seems that to one needs to remove the nvidia drivers completely by --purge, otherwise Nouveau drivers won't work). This solved the problem. Thank you! $\endgroup$ – Echows Dec 13 '13 at 14:52

I had the same behavior on my machine and it was related to the NVIDIA display driver for my GTX 580. After installing the latest version of the display driver, the issue disappeared.

  • $\begingroup$ Ditto, although when I ran into this problem I also updated Java so couldn't figure out the root cause. $\endgroup$ – bobthechemist Nov 27 '13 at 16:52

try workaround in https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1256561 while it worked for me on the desktop, it does not solve it on the laptop where i still get occasional crashes, mostly on exit from the mathematica frontend.


This is a long-shot... My system locks-up whenever I rotate a 3D plot with the mouse: Scientific Linux 6.4 x86_64, GTX 560, nVidia driver version 331.20. Disabling the X Composite extension seems to work for me:

Create the file /etc/X11/xorg.conf.d/no-composite.conf (or the Ubuntu equivalent):

Section "Extensions"
    Option "Composite" "Disable"

Reboot. Of course you wont be able to have a composite desktop... but at least for me it solved my nVidia crashes. YMMV

  • 2
    $\begingroup$ For some reason I get no picture to the monitor if I do this. Thanks for suggestion, though. $\endgroup$ – Echows Nov 29 '13 at 11:14
  • $\begingroup$ Because you're probably using a composite desktop environment (Gnome 3 or Unity)... disable composite and those wont work. Look into switching to a non-composite desktop. I recommend XFCE4. I'm in Gnome 2 w/o composite ("desktop effects") so it works here. $\endgroup$ – cjpembo Nov 29 '13 at 23:14
  • $\begingroup$ Doesn't fix anything for me on Xubuntu & AMD graphics, though I edited /etc/X11/xorg.conf instead (as suggested by askubuntu.com/questions/4662/…) $\endgroup$ – Ponkadoodle Apr 4 '14 at 4:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.