11
$\begingroup$

Bug introduced in 9.0 or earlier and fixed in 10.3.0


I am trying to get the Green's function of a toy diffusion equation

$$\frac{\partial^2 u(x,t)}{\partial x^2} = \frac{1}{\alpha^2}\frac{\partial u(x,t)}{\partial t}$$

with Mathematica 9. Then solve it by inverse Fourier transform:

u[x_, t_] := InverseFourierTransform[U[k, t], k, x]
D[u[x, t], {x, 2}]  
D[D[u[x, t], x], x] 

(* 0 *)
(* InverseFourierTransform[-k^2 U[k, t], k, x] *) 

But can someone tell me why Out[4] and Out[5] are different? Thanks for your kindness.

$\endgroup$
  • $\begingroup$ I'd say it is a bug. You can see from the trace also where the different behavior is: Trace[D[u[x, t], {x, 2}]] vs. Trace[D[D[u[x, t], x], x]] shows this: !Mathematica graphics Mathematically speaking, both should give same result. Maple gives same result as you can see !Mathematica graphics $\endgroup$ – Nasser Nov 10 '13 at 8:20
  • $\begingroup$ Thanks @Nasser for the trace info. I will contact wolfram to confirm that shortly. $\endgroup$ – Guo Nov 10 '13 at 9:19
  • $\begingroup$ @b.gatessucks Thanks for your reply. But that u is what I am trying to solve. $\endgroup$ – Guo Nov 10 '13 at 14:46
  • $\begingroup$ I see, I had misunderstood your question. $\endgroup$ – b.gates.you.know.what Nov 10 '13 at 14:59
  • $\begingroup$ @Guo would you care to post that as an official answer to your question, so that we can consider this issue closed and mark it as a bug for our site? $\endgroup$ – Oleksandr R. Nov 25 '13 at 2:45
8
$\begingroup$

Thanks for all your generous help. The wolfram technical support has just confirmed the issue originates from the first derivative of inverse Fourier transform. Actually D[u[x, t], x] should output InverseFourierTransform[I k U[k, t], k, x] rather than InverseFourierTransform[-I k U[k, t], k, x].

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.