I decided it was time I investigated CDFs, so I created the following simple Manipulate using Mathematica version

  Sin[a x], {x, 0, 2 Pi}
 {a, 1, 10},
 SaveDefinitions -> True]

simple manipulate

Then I selected File>CDF Preview>CDF Player

file cdf preview

which produced a new window:

cdf preview

Not very interesting (a bit like yesterday's paper — flat, lifeless, inactive), but perhaps that's what it's supposed to look like at this point. I pressed on, and used the wizard (File>CDF Export>Standalone...) to save a CDF version of the notebook.

cdf wizard

I put the new CDF file in a trusted directory, then opened the Wolfram CDF Player (version and tried to open the file. Nothing happened - no console messages. I know that the CDF Player works, because I can open CDFs downloaded from demonstrations.wolfram.com.

The CDF file itself can be opened in Mathematica and works as expected. I tried opening it in CDF player with Mathematica running, and also after quitting Mathematica. I also tried with CDFs made using File>SaveAs... -> CDF.

I've read the CDF-tagged questions here, but can't find anything that addresses my basic inability to create a simple CDF.

  • $\begingroup$ I can't reproduce this behaviour. Everything works ok on WinXp MMA nad on CDFPlayer What if you try to create a CDF with only the output cell with current selection marked in Step 2of deploynment process? $\endgroup$
    – Kuba
    Commented Sep 18, 2013 at 8:04
  • $\begingroup$ @kuba - I did wonder whether my installation had gone awry somehow. If it works for everyone else, I'll have to re-install. (Current selection didn't work either.) $\endgroup$
    – cormullion
    Commented Sep 18, 2013 at 8:08
  • $\begingroup$ After CDF Preview, I got it working in a MS Surface Pro. Before you reinstall your Mathematica license on your Mac, you might be interested in mathematica.stackexchange.com/questions/29809/…. $\endgroup$
    – Hector
    Commented Sep 18, 2013 at 8:10
  • 3
    $\begingroup$ @hector :) Nice try, Steve Ballmer! $\endgroup$
    – cormullion
    Commented Sep 18, 2013 at 8:15
  • $\begingroup$ Have you altered the default stylesheet? It looks like there's an opener for your input cell that I don't see by default in a windows version. $\endgroup$ Commented Sep 18, 2013 at 9:04

1 Answer 1


I traced the problem to this line in my init.m:


I'm not sure how it got set to false, probably me fiddling with some options one day, but once it's set to True it's possible to create CDFs in the usual way.

  • $\begingroup$ May I ask how have you traced it? $\endgroup$
    – Kuba
    Commented Sep 18, 2013 at 16:50
  • 1
    $\begingroup$ @kuba Removed the support folder, it worked, so replaced it. Removed init.m, it worked, so replaced it. Then a binary split test - remove half the file, if it works, then the problem is in the other half; repeat until the problem is isolated. Only took 1/2 hour :) $\endgroup$
    – cormullion
    Commented Sep 18, 2013 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.