3
$\begingroup$

Looking at Documentation for ListSurfacePlot3D, I follow the basic example presented there.

data = ExampleData[{"Geometry3D", "StanfordBunny"}, "VertexData"];
ListSurfacePlot3D[data, MaxPlotPoints -> 50, Mesh -> 30, Axes -> None,
  MeshFunctions -> (#1 - #2 + #3 &), MeshShading -> {None, Yellow}]

What happens is that, first of all the vertex data from Stanford Bunny is read and stored in data, but then running ListSurfacePlot3D returns no output (I was expecting a graphic object as shown in documentation). In fact after running the line with ListSurfacePlot3D I see that data is cleared from workspace (it doesn't contain any data, in fact it is not even defined anymore - changing color from black to blue).

It seems that MeshShading is causing this problem, so the following works:

data = ExampleData[{"Geometry3D", "StanfordBunny"}, "VertexData"];
ListSurfacePlot3D[data, MaxPlotPoints -> 50, Mesh -> 30, Axes -> None,
  MeshFunctions -> (#1 - #2 + #3 &)]

enter image description here

I face the same problem when trying other examples from documentation; ListSurfacePlot3D/Options/MeshShading

So, is this a bug or am I missing something?

I am using OS X 10.8.4 64 bit, and Mathematica version 9.0 for Mac OS X x86 (64-bit) (January 24, 2013).

$\endgroup$
  • 2
    $\begingroup$ Here on OSX 10.8.4 and M9.0.1 the kernel crashes with this example from the doc. I think it is OK to tag this bugs even without confirmation of Wolfram. I reported it. $\endgroup$ – halirutan Aug 5 '13 at 14:28
  • $\begingroup$ here's a bit of a workaround ListSurfacePlot3D[data,MaxPlotPoints->50,Mesh->30,Axes->None,MeshFunctions->(#1-#2+#3&),MeshShading->{Opacity[0,White],Yellow} ] $\endgroup$ – chuy Aug 5 '13 at 15:53
  • $\begingroup$ Works perfectly fine under Win 8 and MMA 9.0.1, will check later my Ubuntu version too. $\endgroup$ – Sektor Aug 5 '13 at 15:56
  • $\begingroup$ Works fine in Win 8 v9.0.1 $\endgroup$ – RunnyKine Aug 5 '13 at 16:49
  • $\begingroup$ Works fine with the same OS and Mathematica 8 $\endgroup$ – gpap Aug 5 '13 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.